【PAT】 A1085 Perfect Sequence

Given a sequence of positive integers and another positive integer p. The sequence is said to be a perfect sequence if M≤m×p where M and m are the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (≤10​5​​) is the number of integers in the sequence, and p (≤10​9​​) is the parameter. In the second line there are N positive integers, each is no greater than 10​9​​.

Output Specification:

For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.

Sample Input:

10 8
2 3 20 4 5 1 6 7 8 9

Sample Output:

8

这个二分查找,使用递归函数,只得到了23分,还没想通为什么。

更简单的事调用upper_bound 函数。

后面不使用递归函数,使用循环,并且将乘积的结果,即n*p的结果改为long long 类型通过了。

#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;
/* run this program using the console pauser or add your own getch, system("pause") or input loop */
vector<int> vec;
int n,p;
int find_max(vector<int> &vec,int left_index, int right_index,int cur_index){
	int mid_index = (left_index+right_index)/2;
	if(left_index<right_index){
		if (vec[mid_index]<(vec[cur_index]*p))
			find_max (vec,mid_index+1,right_index,cur_index);
		else
			find_max (vec,left_index,mid_index-1,cur_index);
	}else{
		if(vec[mid_index]<=(vec[cur_index]*p)) return mid_index;
		else return cur_index;
	}
	
}
int main(int argc, char** argv) {
	int tmp;
	cin>>n>>p;
	for(int i=0;i<n;i++){
		cin>>tmp;
		vec.push_back(tmp);
	}
	
	sort(vec.begin(),vec.end());
	
	//for(int i =0;i<vec.size();i++) cout<<vec[i]<<" "; 
	int m_index;
	int max_num=0;
	int right_index;
	int left_index;
	
	for(int i=0;i<vec.size();i++){
		right_index= i+1;
		left_index = vec.size()-1;
		m_index = find_max(vec,right_index,left_index,i);
		int cur_num = m_index - i+1;
		if(cur_num>max_num) max_num = cur_num;
	}

	cout<<max_num<<endl;
	return 0;
}
#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;
/* run this program using the console pauser or add your own getch, system("pause") or input loop */
vector<int> vec;
int n,p;
int find_max(vector<int> &vec,int left_index, int right_index,int cur_index){
	
	while(left_index<right_index){
		int mid_index = (left_index+right_index)/2;
		if(vec[mid_index]<=( long long )vec[cur_index]*p) left_index = mid_index+1;
		else right_index = mid_index-1; 
	}

	int mid_index = (left_index+right_index)/2;
	if(vec[mid_index]<=(long long )vec[cur_index]*p) return mid_index;
	else return cur_index;

}
int main(int argc, char** argv) {
	int tmp;
	cin>>n>>p;
	for(int i=0;i<n;i++){
		cin>>tmp;
		vec.push_back(tmp);
	}
	
	sort(vec.begin(),vec.end());
	
	//for(int i =0;i<vec.size();i++) cout<<vec[i]<<" "; 
	int m_index;
	int max_num=0;
	int right_index;
	int left_index;
	
	for(int i=0;i<vec.size();i++){
		right_index= i+1;
		left_index = vec.size()-1;
		m_index = find_max(vec,right_index,left_index,i);
		int cur_num = m_index - i+1;
		if(cur_num>max_num) max_num = cur_num;
	}

	cout<<max_num<<endl;
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值