PAT甲级1085 Perfect Sequence (25 分)【二分法】

1085 Perfect Sequence (25 )

Given a sequence of positive integers and another positive integer p. The sequence is said to be a perfect sequence if Mm×p where M and m are the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (105) is the number of integers in the sequence, and p(109) is the parameter. In the second line there are N positive integers, each is no greater than 109.

Output Specification:

For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.

Sample Input:

10 8
2 3 20 4 5 1 6 7 8 9

Sample Output:

8

      题目大意:

         给出长度为n的序列以及一个参数p,要求选出一定的数字使M<= m * p,M为序列最大值,m为序列最小值,求最多能有多少个数字。

 

思路:

         采用二分法进行查找,每次都固定一个m,找到第一个大于 m * p 的元素即可。

 

参考代码:

 

 

#include<cstdio>
#include<algorithm>
#include<vector>
using namespace std;
vector<long long> list;
int n, p;
int main(){
	scanf("%d%d", &n, &p);
	list.resize(n);
	for(int i = 0; i < n; ++i)	scanf("%lld", &list[i]);
	sort(list.begin(), list.end());
	int cnt = 0;
	for(int i = 0; i < n; ++i){
		int j = upper_bound(list.begin() + i + 1, list.end(), (long long) list[i] * p) - list.begin();
		cnt = max(cnt,  j - i);
	}
	printf("%d", cnt);
	return 0;
}

如果不用upper_bound函数,这里提供binary search 函数:

int binarysearch(int i, long long x){
	if(a[n - 1] <= x)	return n;
	int l = i + 1, r = n - 1;
	while(l < r){
		int mid = (l + r) / 2;
		if(a[mid] <= x)	l = mid + 1;
		else r = mid;
	}
	return l;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值