费马小定理 A/B

要求(A/B)%9973,但由于A很大,我们只给出n(n=A%9973)(我们给定的A必能被B整除,且gcd(B,9973) = 1)。

Input

数据的第一行是一个T,表示有T组数据。 
每组数据有两个数n(0 <= n < 9973)和B(1 <= B <= 10^9)。

Output

对应每组数据输出(A/B)%9973。

Sample Input

2
1000 53
87 123456789

Sample Output

7922
6060
#include<iostream>
#include<math.h>
#include<cstdio> 
#define LL long long 
using namespace std;

LL pow_mod(LL a,LL b,LL p){
	LL s=1;//忘记赋初值,,,,,,,所以错了!!! 
	while(b){
		if(b & 1) s=(s*a)%p;
		a=(a*a)%p;
		b>>=1;
	}
	return s;
}

LL fmat(LL a,LL p){
	return pow_mod(a,p-2,p);
}

int main(){
	LL n,a,b;
	cin>>n;
	while(n--){
		cin>>a>>b;
		LL t;
		t=fmat(b,9973);
		LL ans;
		ans=(a*(t))%9973;
		printf("%lld\n",ans);
	}
	
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值