HDU 1711 Number Sequence (kmp匹配基础模板)

Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one. 

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000]. 

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead. 

Sample Input

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

Sample Output

6
-1

 

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
int s[1000005],t[10005];//s数组为母串,t为模式串(即子串)
int n,m;
int nxt[10005];//该数组表示该点后一个位置不同时应该跳到的位置

void getnxt(){    //得到模式串的前缀最长公共子串长度数组
	int i=1,j=0;
	nxt[0]=0;
	while(i<m){
		if(t[i]==t[j]){    //相同则i,j都往后移一位,++j表示要跳到的下一个位置
			nxt[i++]=++j;
		}else if(!j){    //如果j是0,则j不能往前退了,所以只能i往后走了
			i++;
		}else{
			j--;//一步一步往前退,易理解 
			//j=nxt[j-1];节省时间,快 
		}
	}
}

int kmp(){
	int i=0,j=0;
	while(i<n&&j<m){
		if(s[i]==t[j]){
			i++;
			j++;
		}else if(!j){
			i++;
		}else{
			j=nxt[j-1];
		}
	}
	if(j==m) return i-m+1;//返回能够匹配的母串中的第一个字母(数字)的位置
	else return -1;//不能匹配
	
}

int main(){
	int T;
	scanf("%d",&T);
	while(T--){
		scanf("%d%d",&n,&m);
		int i;
		for(i=0;i<n;i++) scanf("%d",&s[i]);
		for(i=0;i<m;i++) scanf("%d",&t[i]);
		getnxt();
		printf("%d\n",kmp());
	}
	return 0;
}

 

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值