The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.
The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:
'X': a block of wall, which the doggie cannot enter;
'S': the start point of the doggie;
'D': the Door; or
'.': an empty block.
The input is terminated with three 0's. This test case is not to be processed.
Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
Sample Input
4 4 5
S.X.
..X.
..XD
....
3 4 5
S.X.
..X.
...D
0 0 0
Sample Output
NO
YES
参考了别的博客,才知道还有奇偶剪枝这种方法。
还有根据题意巧妙地减少计算时间,
而且,要读清题意:是T时间刚好到达!!!
emmmmm......深搜如果是要找具体的路线,就要用到回溯,其实就是这个点往后不满足要求,就退回去一步,所以要把现在走的那个点的标记抹掉。
#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
#define MAX 15
using namespace std;
char mp[MAX][MAX];
bool vis[MAX][MAX];
int n,m,T;
int ans,ex,ey;
int dir[2][4]={{1,-1,0,0},{0,0,1,-1}};
void dfs(int ox,int oy,int t){
if(mp[ox][oy]=='D'&&t==T) { ans=1;return ;}//表示找到了
if(ans==1) return ;//出现一个满足要求的方案即可
if(t>T) return ;//超时的不要
int temp=abs(ex-ox)+abs(ey-oy);
temp=T-t-temp;
if(temp<0||temp&1) return ;//奇偶剪枝,如果没它,会超时;并且如果剩余的步数不能到出口,就剪掉
int i,x,y;
for(i=0;i<4;++i){
x=ox+dir[0][i];
y=oy+dir[1][i];
if(x>=0&&x<n&&y<m&&y>=0&&!vis[x][y]&&mp[x][y]!='X'){
vis[x][y]=1;
dfs(x,y,t+1);
if(ans==1) return ;
vis[x][y]=0; //回溯
}
}
return ;
}
int main(){
while(~scanf("%d%d%d",&n,&m,&T)&&(n||m||T)){
int i,j,ox,oy,wall=0;
ans=0;
memset(mp,0,sizeof(mp));
memset(vis,0,sizeof(vis));
for(i=0;i<n;++i) scanf("%s",mp[i]);
for(i=0;i<n;++i){
for(j=0;j<m;++j){
if(mp[i][j]=='S'){
ox=i;oy=j;
}
if(mp[i][j]=='D'){
ex=i;ey=j;
}
if(mp[i][j]=='X'){
wall++;
}
}
}
if(T>n*m-wall-1){
cout<<"NO"<<endl;
continue;
}
vis[ox][oy]=1;
dfs(ox,oy,0);
if(ans==1) cout<<"YES"<<endl;
else cout<<"NO"<<endl;
}
return 0;
}