HDU - 1711——Number Sequence (KMP入门题)

Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
Input The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
Output For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1
Sample Output
6
-1

题意:找出上串中最早出现下串的下标。
思路:简单的KMP问题。直接套用KMP模板即可。
#include<stdio.h>
#include<algorithm>
#include<string.h>
int S[1000010],T[10010],nextt[10010];
int t,n,m;
void prepare_kmp()
{
    int j=0;
    for(int i=1;i<=m;)
    {
        if(j==0||T[i]==T[j])
        {
            nextt[++i]=++j;
        }
        else
            j=nextt[j];
    }
}
void KMP()
{
    int j=1,i;
    for(i=1;i<=n;)
    {
        if(j==0||T[j]==S[i])
        {
            j++;
            i++;
        }
        else
            j=nextt[j];
        if(j>m)
            break;
    }
    if(j>m)
        printf("%d\n",i-j+1);
    else
        printf("%d\n",-1);
}
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++)
            scanf("%d",&S[i]);
        for(int i=1;i<=m;i++)
            scanf("%d",&T[i]);
        prepare_kmp();
        KMP();
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值