1040 Longest Symmetric String (25)

1040 Longest Symmetric String (25)【暴力求解,精悍的代码】

Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given "Is PAT&TAP symmetric?", the longest symmetric sub-string is "s PAT&TAP s", hence you must output 11.

Input Specification:

Each input file contains one test case which gives a non-empty string of length no more than 1000.

Output Specification:

For each test case, simply print the maximum length in a line.

Sample Input:

Is PAT&TAP symmetric?

Sample Output:

11

网上看了还多都是50行起步的代码,使用了STL精简比较和倒序功能的代码后可缩短到不到30行。(成功AC)

原题:传送门

#include <iostream>
#include <string>
#include <algorithm>
using namespace std;
int main()
{
	int max=-1,cnt=0;
	string str;
	getline(cin,str);
	for(int i=0;i<str.size();++i)
	{
		for(int j=1;j<=str.size()-i;++j)
		{
			string temp=str.substr(i,j);
			string revs=temp;
			reverse(revs.begin(),revs.end());
			if(!temp.compare(revs) && j>max)
				max=j;
		}
	}
	cout<<max;
	system("pause");
	return 0;
}

 

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值