2024HBCPC:C Goose Goose Duck

题目描述

Iris 有 n n n 个喜欢玩鹅鸭杀的朋友,编号为 1 ∼ n 1∼n 1n。 假期的时候,大家经常会在群里问有没有人玩鹅鸭杀,并且报出现在已经参与的人数。 但是每个人对于当前是否加入游戏都有自己的想法。 具体的来说,对于第 i i i 个人,如果当前已经加入游戏的人数处于区间 [ l i , r i ] [l_i,r_i] [li,ri] 之间,那 ta 就会愿意加入游戏。 你认为参与游戏的人越多,游戏将会越有趣,所以你决定给大家安排一个加入顺序,使得加入游戏的人数最多。

Input

第一行,一个整数 n ( 1 ≤ n ≤ 1 0 6 ) n (1≤n≤10^6) n(1n106),表示总人数。 接下来 n n n 行,每行为两个由空格分隔的整数 l i , r i ( 0 ≤ l i , r i ≤ 1 0 6 ) l_i,r_i (0≤l_i,r_i≤10^6) li,ri(0li,ri106),含义见题目描述。

Output

第一行一个非负整数 m m m,表示最多能有多少个人加入游戏。 接下来一行 m m m 个整数,由空格分隔,第 i i i 个数为 p i p_i pi,表示第 i i i 个加入游戏的人。

若有多种加入游戏的方案,你可以输出任意一种。

输入样例
5
2 5
4 4
0 2
0 2
1 4
输出样例
5
4 3 5 1 2 
解题思路

考虑贪心,我们很容易可以想到按照左端点从小到大排序,那么对于同一人数时,有多个人可以加入游戏,应该选择右端点最小的人参加游戏,实现这个思路则是用优先队列动态维护右端点最小的人即可

正确代码
#pragma GCC optimize(3, "Ofast", "inline")
#include<bits/stdc++.h>
#define int long long
#define x first
#define y second
#define debug(x) cerr << #x" = " << x << '\n';
using namespace std;

void solve()
{
    int n;
    cin >> n;
    struct node
    {
        int l, r, i;
    };
    auto cmp1 = [](node A, node B)
    {
        return A.l > B.l;
    };
    auto cmp2 = [](node A, node B)
    {
        return A.r > B.r;
    };
    priority_queue<node, vector<node>, decltype(cmp1)> heapl(cmp1); // 左端点小的排前面
    priority_queue<node, vector<node>, decltype(cmp2)> heapr(cmp2); // 右端点小的排前面
    for (int i = 1; i <= n; i++)
    {
        int l, r;
        cin >> l >> r;
        heapl.push({l, r, i});
    }
    int res = 0; // 当前参加游戏的人数
    vector<int> ans; // 答案序列

    while (1)
    {
        // 当前参与游戏的人数达到了这个人的左端点,则把他加入到另一个堆中去
        while (heapl.size() && heapl.top().l == res) 
        {
            heapr.push(heapl.top());
            heapl.pop();
        }
        if (heapr.empty()) break;  // 如果没有人可以参加游戏,则跳出死循环
        ans.push_back(heapr.top().i); // 把右端点最小的人加入答案序列
        res ++; // 参加人数+1
        heapr.pop(); 
        // 如果出现右端点小于当前人数,那么这个人无法参加游戏了,则弹出
        while (heapr.size() && heapr.top().r < res) heapr.pop(); 
    }
    cout << res << '\n';
    for (int i : ans) cout << i << ' ';
}

signed main()
{
    // freopen("Sample.in", "r", stdin);
    ios::sync_with_stdio(false);
    cin.tie(nullptr);
    int T = 1;
    // cin >> T;
    while (T--) solve();
    return 0;
}
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值