UVA - 846-Steps

题目描述:
One steps through integer points of the straight line. The length of a step must be nonnegative and can be by one bigger than, equal to, or by one smaller than the length of the previous step.

What is the minimum number of steps in order to get from x to y? The length of the first and the last step must be 1.

Input and Output
Input consists of a line containing n, the number of test cases. For each test case, a line follows with two integers: 0 x y < 231. For each test case, print a line giving the minimum number of steps to get from x to y.

Sample Input

3
45 48
45 49
45 50

Sample Output

3
3
4

类型:数学题?。。考察思路的
思路: 因为步距由1到某值然后又降到1,要求最小步数,所以步距序列一定是由1升到n再降到1,中间插上平等步距。所以我的思路是求得一个数列:123…n…321前n项和刚好大于要求距离,然后降低n到n-1分析仍差距离(存在一个域)补上步数即可

#include<stdio.h>
#include<stdlib.h>

int main()
{
    int Case;
    scanf("%d", &Case);
    while(Case--)
    {
        int head, tail;
        scanf("%d %d", &head, &tail);
        int num = tail - head;
        int n = 1;
        while(((1+n)*n - n) < num)
            n++;
        n--;
        if((num -((1+n)*n - n))>n)
            n= 2*n - 1 + 2;
        else
            n= 2*n - 1 + 1;
        printf("%d\n", n);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值