Uva 846 - Steps

Steps

One steps through integer points of the straight line.  The length of a step must be nonnegative and can be by one bigger than, equal to, or  by one smaller than the length of the previous step.

What is the minimum number of steps in order to get from x to y?       

The length of the first and the last step must be 1.

Input and Output

Input consists of a line containing n, the number of test cases.  For each test case, a line follows with two integers:  0$ \le$x$ \le$y < 231. For each test case, print a line giving the minimum number of steps to get from x to y.

Sample Input

3
45 48
45 49
45 50

Sample Output

3
3
4

Miguel Revilla 2002-06-15
 
#include<stdio.h>
#include<string.h>
#include<math.h>
int main()
{
    int T, start, end, mid, leave, n, temp, sum;
    scanf("%d", &T);
    while(T--)
    {
        scanf("%d%d", &start, &end);
        leave = (end-start)%2;
        mid = (end-start)/2;
        n = (int)floor(sqrt(2.0*mid));
        if(n*(n+1)/2 - mid != 0) 
        {
            if(n*(n+1)/2 - mid > 0) n--;
            temp = mid - n*(n+1)/2;
            sum = 2*n;
            if(leave)
            {
                if(temp*2+1 <= n+1) sum++;
                else if(temp+1 <= n+1 || temp*2 <= n+1 ) sum += 2;
                else sum += 3;
            }
            else
            {
                if(temp*2 <= n+1) sum++;
                else sum += 2;
            }
        } 
        else sum = 2*n+leave;
        printf("%d\n", sum);
    }
    return 0;
}

解题报告:

转载于:https://www.cnblogs.com/liaoguifa/archive/2013/03/03/2941657.html

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值