POJ1985 Cow Marathon


Cow Marathon
Time Limit: 2000MS Memory Limit: 30000K
Total Submissions: 5054 Accepted: 2459
Case Time Limit: 1000MS

Description

After hearing about the epidemic of obesity in the USA, Farmer John wants his cows to get more exercise, so he has committed to create a bovine marathon for his cows to run. The marathon route will include a pair of farms and a path comprised of a sequence of roads between them. Since FJ wants the cows to get as much exercise as possible he wants to find the two farms on his map that are the farthest apart from each other (distance being measured in terms of total length of road on the path between the two farms). Help him determine the distances between this farthest pair of farms. 

Input

* Lines 1.....: Same input format as "Navigation Nightmare".

Output

* Line 1: An integer giving the distance between the farthest pair of farms. 

Sample Input

7 6
1 6 13 E
6 3 9 E
3 5 7 S
4 1 3 N
2 4 20 W
4 7 2 S

Sample Output

52

Hint

The longest marathon runs from farm 2 via roads 4, 1, 6 and 3 to farm 5 and is of length 20+3+13+9+7=52. 

Source

[Submit]   [Go Back]   [Status]   [Discuss]

Home Page   Go Back  To top



题意:

    给出各农场之间的距离,求两个农场之间最大的距离。用两次BFS就可以了。


#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
const int maxn=80010;
int n,m;
int head[maxn];
struct node{
	int v,w,next;
}edge[maxn];
int cnt=0;
void addedge(int u,int v,int w)
{
	edge[cnt].v=v;
	edge[cnt].w=w;
	edge[cnt].next =head[u];
	head[u]=cnt++;
}
void fun()
{
	memset(head,-1,sizeof(head));
}
int vis[maxn],dis[maxn],q[maxn],res;
int bfs(int u)
{
	memset(vis,0,sizeof(vis));
	int front=0;
	int rear=1;
	q[1]=u;
	vis[u]=1;
	dis[u]=0;
	int ans=0;
	while(front<rear)
	{
		front++;
		int tmp=q[front];
		for(int i=head[tmp];i!=-1;i=edge[i].next)
		{
			int v=edge[i].v;
			if(!vis[v])
			{
				rear++;
				q[rear]=v;
				vis[v]=1;
				dis[v]=dis[tmp]+edge[i].w ;
				if(dis[v]>ans)
				{
					ans=dis[v];
					res=v;
				}
			}
		}
	}
	return ans;
}
int main()
{
	int u,v,w;
	char ch;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		fun();
		cnt=0;
		for(int i=0;i<m;i++)
		{
			scanf("%d %d %d %c",&u,&v,&w,&ch);
			addedge(u,v,w);
			addedge(v,u,w);
		}
		bfs(1);
		printf("%d\n",bfs(res));
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值