【POJ1985】Cow Marathon(基础 树的直径)

Cow Marathon
Time Limit:2000MS     Memory Limit:30000KB     64bit IO Format:%lld & %llu

Description

After hearing about the epidemic of obesity in the USA, Farmer John wants his cows to get more exercise, so he has committed to create a bovine marathon for his cows to run. The marathon route will include a pair of farms and a path comprised of a sequence of roads between them. Since FJ wants the cows to get as much exercise as possible he wants to find the two farms on his map that are the farthest apart from each other (distance being measured in terms of total length of road on the path between the two farms). Help him determine the distances between this farthest pair of farms. 

Input

* Lines 1.....: Same input format as "Navigation Nightmare".

Output

* Line 1: An integer giving the distance between the farthest pair of farms. 

Sample Input

7 6
1 6 13 E
6 3 9 E
3 5 7 S
4 1 3 N
2 4 20 W
4 7 2 S

Sample Output

52

Hint

The longest marathon runs from farm 2 via roads 4, 1, 6 and 3 to farm 5 and is of length 20+3+13+9+7=52. 

第一种:套用的模板

#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm>
using namespace std;
int dist[40010];//要足够大,不然就runtime error
bool vis[40010];
int head[40010];
int n,m;
struct Edge
{
	int from,to,val,next;
 } edge[80010];
 int edgenum;
void addedge(int u,int v,int w)
{
edge[edgenum].from=u;
edge[edgenum].to=v;
edge[edgenum].val=w;
edge[edgenum].next=head[u];
head[u]=edgenum++;	
}
void init()
{
	edgenum=0;
	memset(head,-1,sizeof(head));
}
int ans;
int node;
void bfs(int s)
{
	queue<int>q;
	memset(dist,0,sizeof(dist));
	memset(vis,false,sizeof(vis));
	q.push(s);
	vis[s]=true;
	ans=0;
	node=s;
	while(!q.empty())
    {
	int u=q.front();
	q.pop();
	for(int i=head[u];i!=-1;i=edge[i].next)
	{
		int v=edge[i].to;
		if(!vis[v])
		{
		if(dist[v]<dist[u]+edge[i].val)
			{
				dist[v]=dist[u]+edge[i].val;
			}
			vis[v]=true;
			q.push(v);
		}
	  }
   }
   for(int i=1;i<=n;i++)//注意是1到n,不是0到n-1
   {
   	if(ans<dist[i])
   	{
   		ans=dist[i];
   		node=i;
	   }
	   }	
}
int main()
{
	int a,b,c;
	char h[2];
	while(~scanf("%d%d",&n,&m))
	{
		init();
		for(int i=0;i<m;i++)
		{
			scanf("%d%d%d%s",&a,&b,&c,&h);
			addedge(a,b,c);
			addedge(b,a,c);
		}
		bfs(1);
		bfs(node);
		printf("%d\n",ans);
	}
}


第二种:参考的别人代码,看起来好简单,然而本渣渣初学不懂,dfs不太会用(╥╯^╰╥)

链接 :http://blog.csdn.net/sio__five/article/details/19016079

using namespace std;  
struct node  
{  
    int x, w;  
};  
int n, m, mx = 0, k;  
vector<node> v[maxn];  
int vis[maxn] = {0};  
void dfs(int x, int s)  
{  
    if (s > mx) mx = s, k = x;  
    for (int i = 0; i < v[x].size(); i++) if (!vis[v[x][i].x])  
    {  
        vis[v[x][i].x] = 1;  
        dfs(v[x][i].x, s + v[x][i].w);  
        vis[v[x][i].x] = 0;  
    }  
}  
int main ()  
{  
    while(scanf("%d%d", &n, &m) != EOF)  
    {  
        int x, y;  
        node tmp;  
        char ch;  
        for (int i = 0; i <= n; i++) v[i].clear();  
        while(m--)  
        {  
            scanf("%d%d%d %c", &x, &y, &tmp.w, &ch);  
            tmp.x = y, v[x].push_back(tmp);  
            tmp.x = x, v[y].push_back(tmp);  
        }  
        mx = 0;  
        mem(vis, 0), vis[1] = 1;  
        dfs(1, 0);  
        mem(vis, 0), vis[k] = 1;  
        dfs(k, 0);  
        cout<<mx<<endl;  
    }  
    return 0;  
}  


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值