HDU-1305 Immediate Decodability (Trie 字典树 入门题)

Immediate Decodability

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3673    Accepted Submission(s): 1917


Problem Description
An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.

Examples: Assume an alphabet that has symbols {A, B, C, D}

The following code is immediately decodable:
A:01 B:10 C:0010 D:0000

but this one is not:
A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)
 

Input
Write a program that accepts as input a series of groups of records from input. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).
 

Output
For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.
 

Sample Input
  
  
01 10 0010 0000 9 01 10 010 0000 9
 

Sample Output
  
  
Set 1 is immediately decodable Set 2 is not immediately decodable

 

#include <bits/stdc++.h>
using namespace std;
#define maxn 1000000
int ch[maxn][2], st[maxn], ps[maxn], tot;
int insert(char s[]){
    int n = strlen(s), k = 0, ans = 0, y;
    for(int i = 0; i < n; ++i){
        y = s[i] - '0';
        if(ch[k][y] == 0){
            ch[k][y] = ++tot;
            ch[tot][0] = ch[tot][1] = 0;
        }
        k = ch[k][y];
        if(i == n - 1){
            ans |= ps[k];
        }
        ps[k] = 1;
        ans |= st[k];
    }
    st[k] = 1;
    return ans;
}
int main(){
    char s[12];
    int casenum = 1, ans = 0;
    tot = ch[0][0] = ch[0][1] = 0; 
    memset(ps, 0, sizeof(ps));
    while(scanf("%s", s) != EOF){
        if(s[0] == '9'){
            if(ans){
                printf("Set %d is not immediately decodable\n", casenum++);
            }
            else{
                printf("Set %d is immediately decodable\n", casenum++);
            }
            ans = tot = ch[0][1] = ch[0][0] = 0; 
            memset(ps, 0, sizeof(ps));
            memset(st, 0, sizeof(st));
            continue;
        }
        ans |= insert(s);    
    }
}

/*
题意:一组01字符串,问是否存在一个字符串是另一个字符串的前缀。

思路:对01串建Trie,在建的过程中即可维护答案。在插入结点时,若某结点
是已有01串末尾结点,那该串一定有前缀。或者在插入该串的末尾时,该结点是已有
数字串的中间结点,那该串一定是某已有串的前缀。(不过用数组写开多大我有点蒙蔽,,希望大佬指点。。。。)
*/

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值