POJ-2481 Cows (树状数组 入门题)

Cows
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 20178 Accepted: 6865

Description

Farmer John's cows have discovered that the clover growing along the ridge of the hill (which we can think of as a one-dimensional number line) in his field is particularly good. 

Farmer John has N cows (we number the cows from 1 to N). Each of Farmer John's N cows has a range of clover that she particularly likes (these ranges might overlap). The ranges are defined by a closed interval [S,E]. 

But some cows are strong and some are weak. Given two cows: cow i and cow j, their favourite clover range is [Si, Ei] and [Sj, Ej]. If Si <= Sj and Ej <= Ei and Ei - Si > Ej - Sj, we say that cow i is stronger than cow j

For each cow, how many cows are stronger than her? Farmer John needs your help!

Input

The input contains multiple test cases. 
For each test case, the first line is an integer N (1 <= N <= 10 5), which is the number of cows. Then come N lines, the i-th of which contains two integers: S and E(0 <= S < E <= 10 5) specifying the start end location respectively of a range preferred by some cow. Locations are given as distance from the start of the ridge. 

The end of the input contains a single 0.

Output

For each test case, output one line containing n space-separated integers, the i-th of which specifying the number of cows that are stronger than cow i

Sample Input

3
1 2
0 3
3 4
0

Sample Output

1 0 0

Hint

Huge input and output,scanf and printf is recommended.

#include <stdio.h>  
#include <string.h>  
#include <algorithm>
using namespace std;
#define maxn 100005
struct tree{
	int l, r, id;
}a[maxn];
int ans[maxn], c[maxn];
bool mysort(tree e1, tree e2){
	if(e1.l == e2.l) return e1.r > e2.r;
	return e1.l < e2.l;
}
inline int lowbit(int x){
	return x & (-x);
}
void add(int x){
	while(x < maxn){
		c[x] += 1;
		x +=lowbit(x);
	}
}
int query(int x){
	int res = 0;
	while(x){
		res += c[x];
		x -= lowbit(x);
	}
	return res;
}
int main(){
	int n;
	while(scanf("%d", &n) != EOF && n != 0){
		memset(c, 0, sizeof(c));
		for(int i = 1; i <= n; ++i){
			scanf("%d %d", &a[i].l, &a[i].r);
			a[i].l += 2;
			a[i].r += 2;
			a[i].id = i;
		}
		sort(a + 1, a + 1 + n, mysort);
		ans[a[1].id] = 0;
		add(a[1].r);
		for(int i = 2; i <= n; ++i){
			ans[a[i].id] = i - 1 - query(a[i].r - 1);
			add(a[i].r);
		}
		int cur = 0;
		for(int i = 2; i <= n; ++i){
			if(a[i].l == a[i - 1].l && a[i].r == a[i - 1].r){
				cur++;
				ans[a[i].id] -= cur;
			}
			else cur = 0;
		}
		for(int i = 1; i <= n; ++i){
			printf("%d%s", ans[i], i == n ? "\n" : " ");
		}
	}
}

/*
题意:1e5个区间,坐标范围1e5,问每个区间有多少个区间包含它。

思路:把所有区间都读进来,然后按l从小到大排序,l相等则按r从大到小排序。
这样遍历时,之前已经访问的区间的左端点一定小于等于当前区间的左端点;如果存在
已经访问的区间左端点等于当前区间的左端点,那么这些区间的右端点一定大于等于当前
区间的右端点。这样对于每个区间,我们只需要计算之前出现的区间有多少个区间的右端点比
自己的右端点大即可,计算后再将该区间的右端点插入树状数组,继续计算后面的区间。
注意处理相等的区间。
*/

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
POJ 2182是一道使用树状数组解决的目,目要求对给定的n个数进行排序,并且输出每个数在排序后的相对位置。树状数组是一种用来高效处理前缀和问的数据结构。 根据引用中的描述,我们可以通过遍历数组a,对于每个元素a[i],可以使用二分查找找到a到a[i-1]中小于a[i]的数的个数。这个个数就是它在排序后的相对位置。 代码中的query函数用来求前缀和,add函数用来更新树状数组。在主函数中,我们从后往前遍历数组a,通过二分查找找到每个元素在排序后的相对位置,并将结果存入ans数组中。 最后,我们按顺序输出ans数组的元素即可得到排序后的相对位置。 参考代码如下: ```C++ #include <iostream> #include <cstdio> using namespace std; int n, a += y; } } int main() { scanf("%d", &n); f = 1; for (int i = 2; i <= n; i++) { scanf("%d", &a[i]); f[i = i & -i; } for (int i = n; i >= 1; i--) { int l = 1, r = n; while (l <= r) { int mid = (l + r) / 2; int k = query(mid - 1); if (a[i > k) { l = mid + 1; } else if (a[i < k) { r = mid - 1; } else { while (b[mid]) { mid++; } ans[i = mid; b[mid = true; add(mid, -1); break; } } } for (int i = 1; i <= n; i++) { printf("%d\n", ans[i]); } return 0; } ``` 这段代码使用了树状数组来完成目要求的排序功能,其中query函数用来求前缀和,add函数用来更新树状数组。在主函数中,我们从后往前遍历数组a,通过二分查找找到每个元素在排序后的相对位置,并将结果存入ans数组中。最后,我们按顺序输出ans数组的元素即可得到排序后的相对位置。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* *3* [poj2182Lost Cows——树状数组快速查找](https://blog.csdn.net/aodan5477/article/details/102045839)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 50%"] - *2* [poj_2182 线段树/树状数组](https://blog.csdn.net/weixin_34138139/article/details/86389799)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 50%"] [ .reference_list ]

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值