POJ-1159 Palindrome (区间dp)

Palindrome
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 64675 Accepted: 22574

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2



#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
short int dp[5001][5001];
char s[5001];
int main(){
	int n;
	scanf("%d", &n);
	scanf("%s", s);
	memset(dp, 0, sizeof(dp));
	for(int d = 1; d < n; ++d){
		for(int i = 0; i + d < n; ++i){
			if(s[i] == s[i + d]){
				dp[i][i + d] = dp[i + 1][i + d - 1];
			}
			else{
				dp[i][i + d] = 1 + min(dp[i][i + d - 1], dp[i + 1][i + d]);
			}
		}
	}
	printf("%d\n", dp[0][n - 1]);
}

/*
题意:
5000的字符串,问最小需要插入多少个字符可以构成一个回文串。

思路:
区间dp,dp[i][j]表示区间[i,j]需要最少需要插入多少个字符才可以构成一个回文串,
如果s[i] == s[j],那么显然dp[i][j] = dp[i + 1][j - 1];如果不想等,那么就需要插入
一个字符,那么就是dp[i][j] = min(dp[i][j - 1], dp[i + 1][j]) + 1。注意用short int,
否则内存会超。
*/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值