HDU-2577 How to Type (线性状态dp)

How to Type

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7298    Accepted Submission(s): 3314


Problem Description
Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.
 

Input
The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.
 

Output
For each test case, you must output the smallest times of typing the key to finish typing this string.
 

Sample Input
  
  
3 Pirates HDUacm HDUACM
 

Sample Output
  
  
8 8 8
Hint
The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8. The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8 The string "HDUACM", can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8


#include <bits/stdc++.h>
using namespace std;
char s[101];
int dp[101][2];
int main(){
	int T;
	scanf("%d", &T);
	while(T--){
		scanf("%s", s + 1);
		int n = strlen(s + 1);
		memset(dp, 0, sizeof(dp));
		dp[0][0] = 0;
		dp[0][1] = 1;
		for(int i = 1; i <= n; ++i){
			if(s[i] >= 'a' && s[i] <= 'z'){
				dp[i][0] = min(dp[i - 1][0] + 1, dp[i - 1][1] + 2);
				dp[i][1] = min(dp[i - 1][0] + 2, dp[i - 1][1] + 2);
			}
			else{
				dp[i][0] = min(dp[i - 1][0] + 2, dp[i - 1][1] + 2);
				dp[i][1] = min(dp[i - 1][0] + 2, dp[i - 1][1] + 1)	;
			}
		}
		printf("%d\n", min(dp[n][0], dp[n][1] + 1));
	}
}

/*
题意:
长度100的字符串,只包含大小写字母,现在需要把这些字母打出来,CapsLock按下之后可以连续打大写字母,
再按一次后变成连续打小写字母。Shift可以做单次大小写的变换。问打完整个字符串最少需要按多少次按键。

思路:
很显然的是,每个字母如何按的决策只和上一个字母的处理有关,这样我们可以用线性状态dp来做。
dp[i][0]表示处理完第i个单词后CapsLock是关的最少需要按多少次按键,dp[i][1]表示CapsLock开着最少需要多少次。
转移根据dp[i - 1][0]和dp[i - 1][1]去转移,这个就讨论一下即可。
*/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值