POJ-1679 The Unique MST (次小生成树)

The Unique MST
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 32996 Accepted: 12007

Description

Given a connected undirected graph, tell if its minimum spanning tree is unique. 

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties: 
1. V' = V. 
2. T is connected and acyclic. 

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E'. 

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.

Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.

Sample Input

2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output

3
Not Unique!
 
#include <cstdio>  
#include <cmath>  
#include <algorithm> 
#include <vector>
#include <string.h>
using namespace std;
struct edge{
	int from, to, val;
	bool operator < (const edge& x) const{
		return val < x.val;
	}
}e[10005];
int p[101], dis[101][101], cnt[10003];
int findset(int x){
	return p[x] == x ? x : p[x] = findset(p[x]); 
}
vector<pair<int, int> > g[101];
void dfs(int rt, int x, int fa, int d){
	dis[rt][x] = d;
	int cur;
	for(int i = 0; i < g[x].size(); ++i){
		cur = g[x][i].first;
		if(cur == fa) continue;
		dfs(rt, cur, x, max(d, g[x][i].second));
	}
}
int main(){
	int T;
	scanf("%d", &T);
	while(T--){
		memset(cnt, 0, sizeof(cnt));
		memset(dis, 0, sizeof(dis));
		int n, m, u, v;
		scanf("%d %d", &n, &m);
		for(int i = 1; i <= n; ++i){
			p[i] = i;
		}
		for(int i = 1; i <= n; ++i){
			g[i].clear();
		}
		for(int i = 1; i <= m; ++i){
			scanf("%d %d %d", &e[i].from, &e[i].to, &e[i].val);
		}
		sort(e + 1, e + 1 + m);
		int ans = 0;
		for(int i = 1; i <= m; ++i){
			u = findset(e[i].from);
			v = findset(e[i].to);
			if(u != v){
				p[u] = v;
				cnt[i] = 1;
				ans += e[i].val;
				g[e[i].from].push_back(make_pair(e[i].to, e[i].val));
				g[e[i].to].push_back(make_pair(e[i].from, e[i].val));
			}
		}
		for(int i = 1; i <= n; ++i){
			dfs(i, i, 0, 0);
		}
		int flag = 0;
		for(int i = 1; i <= m; ++i){
			if(cnt[i] == 0){
				u = e[i].from;
				v = e[i].to;
				if(dis[u][v] == e[i].val){
					flag = 1;
					break;
				}
			}
		}
		if(flag){
			printf("Not Unique!\n");
		}
		else{
			printf("%d\n", ans);
		}
	}
}

/*
题意:
100个点,给出一些边,问其最小生成树是否唯一。

思路:
求次小生成树,看代价是否一样即可。求次小生成树时,先对最小生成树建图,
然后n^2求一下该图上两点间路劲中最大路径。枚举所有最小生成树之外的点,尝试
将它们加进树中,同时在生成的环中减去一条边,显然应该减的就是那条最大的边,
看这颗生成树的代价是否和最小代价一样即可。
*/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值