poj 1251 Jungle Roads 最小生成树

Jungle Roads
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 18327 Accepted: 8322

Description


The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems.

Input
The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above.

Output
The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit.

Sample Input

9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0

Sample Output

216
30

================================================================================

题目大意:看到图就看出来是求最小生成树了吧。说下输入吧,第一行是点数n,n=0结束。后面接n-1行,每行开头一个字母是点的名字,最多26个点名字都是大写字母,后面的数字是跟几个点邻接,然后依次描述邻接连边的边权。


解题思路:裸Kruskal还要什么思路,建完图手打Kruskal不1A都对不起这题。

//Memory: 720K	Time: 16MS

#include<iostream>
#include<cstring>
#include<vector>
#include<algorithm>
using namespace std;

struct edge
{
    edge( int A , int B , int V ):a(A),b(B),v(V){}
    int a , b , v;
    bool operator < ( const edge &e )const   //重载小于号,给sort做准备
    {
        return v < e.v;
    }
};
vector<edge> l;
int father[27] , ans , eN;         //点序号从1开始,并查集初始化也是0,所以数组第一格要留出来
//并查集
int getFather(int x)
{
    return (!father[x])?x:(father[x] = getFather(father[x]));
}

void Union( int x , int y , int v )
{
    int fx = getFather(x);
    int fy = getFather(y);
    if( fx == fy )
        return;
    father[fy] = fx;
    ans += v;
    eN++;
}
//Kruskal算法
void Kruskal(int n)
{
    eN = 0;
    memset(father,0,sizeof(father));
    vector<edge>::iterator it;
    for( it = l.begin() ; it != l.end() ; it++ )
    {
        if( eN == n-1 )
            return;
        Union( it->a , it->b , it->v );
    }
}

int main()
{
    int n;
    while( cin >> n , n )
    {
        l.clear();
        ans = 0;
        for( int i = 0 ; i < n-1 ; i++ )
        {
            char c;
            int num;
            cin >> c >> num;                             //c语言接单字符要仔细处理换行符,太纠结
            while(num--)                                 //这里数据量也不大就用c++的cin接了
            {
                char c1;
                int v;
                cin >> c1 >> v;
                l.push_back(edge(c-'A'+1,c1-'A'+1,v));   //注意点序号从1开始的话要在这里+1
            }
        }
        sort(l.begin(),l.end());                         //默认按边权从小到大排序
        Kruskal(n);
        cout << ans << endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值