POJ 2096

寒假训练七:C题

传送门:http://acm.hust.edu.cn/vjudge/contest/view.action?cid=107154#problem/C

C - C
Time Limit:10000MS     Memory Limit:64000KB     64bit IO Format:%I64d & %I64u

Description

Ivan is fond of collecting. Unlike other people who collect post stamps, coins or other material stuff, he collects software bugs. When Ivan gets a new program, he classifies all possible bugs into n categories. Each day he discovers exactly one bug in the program and adds information about it and its category into a spreadsheet. When he finds bugs in all bug categories, he calls the program disgusting, publishes this spreadsheet on his home page, and forgets completely about the program. 
Two companies, Macrosoft and Microhard are in tight competition. Microhard wants to decrease sales of one Macrosoft program. They hire Ivan to prove that the program in question is disgusting. However, Ivan has a complicated problem. This new program has s subcomponents, and finding bugs of all types in each subcomponent would take too long before the target could be reached. So Ivan and Microhard agreed to use a simpler criteria --- Ivan should find at least one bug in each subsystem and at least one bug of each category. 
Macrosoft knows about these plans and it wants to estimate the time that is required for Ivan to call its program disgusting. It's important because the company releases a new version soon, so it can correct its plans and release it quicker. Nobody would be interested in Ivan's opinion about the reliability of the obsolete version. 
A bug found in the program can be of any category with equal probability. Similarly, the bug can be found in any given subsystem with equal probability. Any particular bug cannot belong to two different categories or happen simultaneously in two different subsystems. The number of bugs in the program is almost infinite, so the probability of finding a new bug of some category in some subsystem does not reduce after finding any number of bugs of that category in that subsystem. 
Find an average time (in days of Ivan's work) required to name the program disgusting.

Input

Input file contains two integer numbers, n and s (0 < n, s <= 1 000).

Output

Output the expectation of the Ivan's working days needed to call the program disgusting, accurate to 4 digits after the decimal point.

Sample Input

1 2

Sample Output

3.0000

题意:有n种bug分别在s个子目录下

主角每天发现一个bug,肯定属于n种bug且在s个子目录中

一共无数个bug,问发现所有种bug已经所有子目录的bug所需天数的期望值


概率DP,dp[i][j]为找到了i种bug且在j个子目录下所需的时间期望这样dp[n][s]=0,输出dp[0][0]即可

这样dp[i][j]可以分成转化为4种

dp[i][j]表示发现的bug在已知的i种bug中且在已知的j个子目录中

dp[i+1][j]表示发现的bug不在已知的i种bug中且在已知的j个子目录中

dp[i][j+1]表示发现的bug在已知的i种bug中且不在已知的j个子目录中

dp[i+1][j+1]表示发现的bug不在已知的i种bug中且不在已知的j个子目录中

这样dp[i,j]=p1*dp[i,j]+p2*dp[i+1,j]+p3*dp[i,j+1]+p4*dp[i+1,j+1]+1;

其中p1,p2,p3,p4分别代表可能出现的概率

即p1=i*j/(n*s)

p2=(n-i)*j/(n*s)

p3=i*(s-j)/(n*s)

p4=((n-i)*(s-j))/(n*s)

由此往下推即可


这题目看了好久才看懂啊

概率dp也是完全不会,写出来递推也不知道要加上1表示一天过去

提交的时候G++一直过不了,改成C++才过

下面代码

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<stdlib.h>
#include<iostream>
#include<algorithm>
#include<functional>
#include<queue>
#include<vector>
#include<set>
#include<map>
using namespace std;

double dp[2005][2005];

int main()
{
	int n,s,i,j;
	
	while(~scanf("%d%d",&n,&s))
	{
		memset(dp,0,sizeof(dp));
		dp[n][s]=0;
		for(i=n;i>=0;i--)
			for(j=s;j>=0;j--)
			{
				if(i==n && j==s) continue;
				dp[i][j]=(n*s+(n-i)*j*dp[i+1][j]+i*(s-j)*dp[i][j+1]+(n-i)*(s-j)*dp[i+1][j+1])/((n*s)-(i*j));
			}
		printf("%.4lf\n",dp[0][0]);
	}
	return 0;
} 



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值