HDU 5750

传送门:http://acm.hdu.edu.cn/showproblem.php?pid=5750

Dertouzos

Time Limit: 7000/3500 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 871    Accepted Submission(s): 268


Problem Description
A positive proper divisor is a positive divisor of a number  n , excluding  n  itself. For example, 1, 2, and 3 are positive proper divisors of 6, but 6 itself is not.

Peter has two positive integers  n  and  d . He would like to know the number of integers below  n  whose maximum positive proper divisor is  d .
 

Input
There are multiple test cases. The first line of input contains an integer  T   (1T106) , indicating the number of test cases. For each test case:

The first line contains two integers  n  and  d   (2n,d109) .
 

Output
For each test case, output an integer denoting the answer.
 

Sample Input
  
  
9 10 2 10 3 10 4 10 5 10 6 10 7 10 8 10 9 100 13
 

Sample Output
  
  
1 2 1 0 0 0 0 0 4

题意:给出t个n和d,让你求小于n的数中最大约数(不包括本身)为d的数量


题解:要使最大因数为d,必存在x*d=m,同时x必须为质数,且x必须小于d的最小质因数,因此找n前面有几个m即可

因为t范围很大,所以可以先筛选出质数表再线性扫一遍


恩,果然数论超级差系列

问题数论差就算了做题还有谜之自信这个方法肯定对...要检讨一下了


下面代码

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
#include<stdlib.h>
#include<math.h>
#include<map>
#include<vector>
#include<set>
#include<queue>
using namespace std;

int isprime[100005]={0};
int primelist[100005]={0};
int k=0;

int prime()
{
	int i,j;
	
	for(i=2;i<100000;i++)
	{
		if(isprime[i]==0)
		{
			for(j=2;i*j<100000;j++)
				isprime[i*j]=1;
			primelist[k]=i;
			k++;
		}
	}
	return 0;
}

int main()
{
	int t,i;
	int m,n;
	
	scanf("%d",&t);
	prime();
	while(t--)
	{
		cin>>m>>n;

		for(i=0;i<k;i++)
		{
			if(n*primelist[i]>=m) break;
			if(n<primelist[i]) break;
			if(n%primelist[i]==0) break;
		}
		if(n*primelist[i]>=m || n<primelist[i]) i--;
		printf("%d\n",i+1);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值