Tempter of the Bone(搜索)

Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

‘X’: a block of wall, which the doggie cannot enter;
‘S’: the start point of the doggie;
‘D’: the Door; or
‘.’: an empty block.

The input is terminated with three 0’s. This test case is not to be processed.
Output
For each test case, print in one line “YES” if the doggie can survive, or “NO” otherwise.
Sample Input
4 4 5
S.X.
..X.
..XD
….
3 4 5
S.X.
..X.
…D
0 0 0
Sample Output
NO
YES
Author
ZHANG, Zheng
Source
ZJCPC2004
题意:在n行,m列的迷宫中,从S到D恰好走Ts是否能到达,不能走重复的路;
思路:本题如果简单的深搜一般会超时,需要用到剪纸,即
if(zs-ds>0) zs是如果没有障碍到D的最短距离,ds是需要的时间减去已经消耗的时间;
return;
if((ds-zs)%2!=0)
return;
代码:

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
char map[8][8];
int mark[8][8];
int vis[4][2]={0,1,0,-1,1,0,-1,0};
int zx,zy;
int n,m,T;
int flag;
int ok(int x,int y)
{
    if(x>=1&&x<=n&&y>=1&&y<=m&&map[x][y]!='X')
       return 1;
    else
       return 0;
}
void dfs(int x,int y,int s)
{
    if(flag) return;
    int zs=abs(zx-x)+abs(zy-y);
    int ds=abs(s-T);
    if(zs-ds>0)
       return;
    if((ds-zs)%2!=0)
       return;
    if(x==zx&&y==zy&&s==T)
    {
       flag=1;
       return;
    }
    for(int i=0;i<=3;i++)
    {
        int dx=x+vis[i][0];
        int dy=y+vis[i][1];
        if(ok(dx,dy)&&!mark[dx][dy])
        {
            mark[dx][dy]=1;
            s++;
            dfs(dx,dy,s);
            mark[dx][dy]=0;
            s--;
        }
    }
}
int main()
{
    while(~scanf("%d%d%d",&n,&m,&T))
    {
        flag=0;
        int xx,yy;
        int i,j;
        if(n==0&&m==0&&T==0)
           break;
        for(i=1;i<=n;i++)
           scanf("%s",map[i]+1);
        for(i=1;i<=n;i++)
           for(j=1;j<=m;j++)
           {
              if(map[i][j]=='D')
              {
                  zx=i;zy=j;
              }
              else if(map[i][j]=='S')
              {
                  xx=i;yy=j;
              }
           }
        memset(mark,0,sizeof(mark));
        mark[xx][yy]=1;
        dfs(xx,yy,0);
        if(flag==0)
           printf("NO\n");
        else
           printf("YES\n");
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值