hdu 2717 Catch That Cow (BFS)

Problem Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
题意:在x坐标上,农夫在n,牛在k。农夫每次可以移动到n-1, n+1, n*2的点。求最少到达k的步数。

简单BFS

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
using namespace std;
struct node
{
    int x,t;
};
int n,k;
int mark[100005];
int ok(int x)
{
    if(x>=0&&x<=100000)
        return 1;
    else
        return 0;
}
int bfs()
{
    node q,p;
    q.x=n,q.t=0;
    queue<node>que;
    que.push(q);
    while(que.size())
    {
        q=que.front();
        que.pop();
        if(q.x==k)
            return q.t;
        p.x=q.x+1;
        if(ok(p.x)&&!mark[p.x])
        {
            p.t=q.t+1;
            mark[p.x]=1;
            que.push(p);
        }
        p.x=q.x-1;
        if(ok(p.x)&&!mark[p.x])
        {
            p.t=q.t+1;
            mark[p.x]=1;
            que.push(p);
        }
        p.x=q.x*2;
        if(ok(p.x)&&!mark[p.x])
        {
            p.t=q.t+1;
            mark[p.x]=1;
            que.push(p);
        }
    }
    return 0;
}
int main()
{
    while(~scanf("%d%d",&n,&k))
    {
        memset(mark,0,sizeof(mark));
        mark[n]=1;
        printf("%d\n",bfs());
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值