hdu 3652 B-number (数位DP)

20 篇文章 0 订阅
Problem Description
A wqb-number, or B-number for short, is a non-negative integer whose decimal form contains the sub- string "13" and can be divided by 13. For example, 130 and 2613 are wqb-numbers, but 143 and 2639 are not. Your task is to calculate how many wqb-numbers from 1 to n for a given integer n.
 

Input
Process till EOF. In each line, there is one positive integer n(1 <= n <= 1000000000).
 

Output
Print each answer in a single line.
 

Sample Input
  
  
13 100 200 1000
 

Sample Output
  
  
1 1 2 2
 

题意:问1~n中包含"13"序列且能被13整除的数有多少个。
思路:记忆化搜索+数位DP;
dp[i][j][k]:i表示位数,j表示被13除的余数;
k==0 不包含13且不以1结尾  k==1 不包含13且以1结尾  k==2 包含13
代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int dp[15][15][3];
int num[15];
int ok(int a,int b)
{
    if(a==0)
    {
        if(b==1)  return 1;
        else      return 0;
    }
    else if(a==1)
    {
        if(b==3)  return 2;
        else if(b==1)  return 1;
        else  return 0;
    }
    else
        return 2;
}
int dfs(int len,int p,int f,int flag)
{
    if(len<=0)
       return p==0&&f==2;
    if(!flag&&dp[len][p][f]!=-1)
        return dp[len][p][f];
    int end=flag?num[len]:9;
    int ans=0;
    for(int i=0;i<=end;i++)
    {
        ans=ans+dfs(len-1,(p*10+i)%13,ok(f,i),flag&&i==end);
    }
    if(!flag)
        dp[len][p][f]=ans;
    return ans;
}
int solve(int n)
{
    int len=0;
    while(n)
    {
        num[++len]=n%10;
        n=n/10;
    }
    return dfs(len,0,0,1);
}
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        memset(dp,-1,sizeof(dp));
        printf("%d\n",solve(n));
    }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值