poj 2096 Collecting Bugs (概率DP)

Collecting Bugs
Time Limit: 10000MS Memory Limit: 64000K
Total Submissions: 4955 Accepted: 2461
Case Time Limit: 2000MS Special Judge
Description

Ivan is fond of collecting. Unlike other people who collect post stamps, coins or other material stuff, he collects software bugs. When Ivan gets a new program, he classifies all possible bugs into n categories. Each day he discovers exactly one bug in the program and adds information about it and its category into a spreadsheet. When he finds bugs in all bug categories, he calls the program disgusting, publishes this spreadsheet on his home page, and forgets completely about the program.
Two companies, Macrosoft and Microhard are in tight competition. Microhard wants to decrease sales of one Macrosoft program. They hire Ivan to prove that the program in question is disgusting. However, Ivan has a complicated problem. This new program has s subcomponents, and finding bugs of all types in each subcomponent would take too long before the target could be reached. So Ivan and Microhard agreed to use a simpler criteria — Ivan should find at least one bug in each subsystem and at least one bug of each category.
Macrosoft knows about these plans and it wants to estimate the time that is required for Ivan to call its program disgusting. It’s important because the company releases a new version soon, so it can correct its plans and release it quicker. Nobody would be interested in Ivan’s opinion about the reliability of the obsolete version.
A bug found in the program can be of any category with equal probability. Similarly, the bug can be found in any given subsystem with equal probability. Any particular bug cannot belong to two different categories or happen simultaneously in two different subsystems. The number of bugs in the program is almost infinite, so the probability of finding a new bug of some category in some subsystem does not reduce after finding any number of bugs of that category in that subsystem.
Find an average time (in days of Ivan’s work) required to name the program disgusting.
Input

Input file contains two integer numbers, n and s (0 < n, s <= 1 000).
Output

Output the expectation of the Ivan’s working days needed to call the program disgusting, accurate to 4 digits after the decimal point.
Sample Input

1 2
Sample Output

3.0000

**

题意:有s个系统,有n种bug,bug的数量不限,一位程序员每天可以发现一个bug
现在求发现n种bug存在s个系统中并且每个系统都要被发现bug的平均天数(期望)
分析:在这里有s,n两个变量,假设dp[i][j]表示已经发现i种bug存在j个系统到目标所需要的天数,显然dp[n][s]=0;
从dp[i][j]经过一天后可能得到以下四种情况: dp[i][j]->dp[i+1][j+1];//在一个新的系统里面发现一个新的bug
dp[i][j]->dp[i+1][j];//在原来已发现过bug的系统里发现一个新的bug
dp[i][j]->dp[i][j+1];//在一个新的系统里面发现一个已被发现过的bug
dp[i][j]->dp[i][j];//在已发现过bug的系统发现已发现过的bug 四种到达的概率分别是:
p1=(n-i)(s-j)/(n*s); p2=(n-i)*j/(n*s); p3=i(s-j)/(n*s);
p4=i*j/(n*s);
然后根据E(aA+bB+cC+dD+…)=aEA+bEB+….;//a,b,c,d…表示概率,A,B,C…表示状态
所以dp[i][j]=p1*dp[i+1][j+1]+p2*dp[i+1][j]+p3*dp[i][j+1]+p4*dp[i][j]+1;//dp[i][j]表示的就是到达状态i,j的期望

=>dp[i][j]=(p1*dp[i+1][j+1]+p2*dp[i+1][j]+p3*dp[i][j+1]+1)/(1-p4);

**
代码:

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
double dp[1005][1005];
int n,s;
int main()
{
    while(~scanf("%d%d",&n,&s))
    {
        memset(dp,0,sizeof(dp));
        for(int i=n;i>=0;i--)
        {
            for(int j=s;j>=0;j--)
            {
                if(i==n&&j==s)
                    continue;
                double p1=(n-i)*(s-j)*1.0;
                double p2=(n-i)*j*1.0;
                double p3=i*(s-j)*1.0;
                double p4=n*s-i*j*1.0;
                dp[i][j]=(p1*dp[i+1][j+1]+p2*dp[i+1][j]+p3*dp[i][j+1]+n*s)/p4;
            }
        }
        printf("%.4lf\n",dp[0][0]);
    }
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值