poj 3013 Big Christmas Tree (最短路)

Description

Christmas is coming to KCM city. Suby the loyal civilian in KCM city is preparing a big neat Christmas tree. The simple structure of the tree is shown in right picture.

The tree can be represented as a collection of numbered nodes and some edges. The nodes are numbered 1 through n. The root is always numbered 1. Every node in the tree has its weight. The weights can be different from each other. Also the shape of every available edge between two nodes is different, so the unit price of each edge is different. Because of a technical difficulty, price of an edge will be (sum of weights of all descendant nodes) × (unit price of the edge).

Suby wants to minimize the cost of whole tree among all possible choices. Also he wants to use all nodes because he wants a large tree. So he decided to ask you for helping solve this task by find the minimum cost.

Input

The input consists of T test cases. The number of test cases T is given in the first line of the input file. Each test case consists of several lines. Two numbers ve (0 ≤ ve ≤ 50000) are given in the first line of each test case. On the next line, v positive integers wi indicating the weights of v nodes are given in one line. On the following e lines, each line contain three positive integers abc indicating the edge which is able to connect two nodes a and b, and unit price c.

All numbers in input are less than 216.

Output

For each test case, output an integer indicating the minimum possible cost for the tree in one line. If there is no way to build a Christmas tree, print “No Answer” in one line.

Sample Input

2
2 1
1 1
1 2 15
7 7
200 10 20 30 40 50 60
1 2 1
2 3 3
2 4 2
3 5 4
3 7 2
3 6 3
1 5 9

Sample Output

15
1210

Source

POJ Monthly--2006.09.29, Kim, Chan Min (kcm1700@POJ)


题意:题意:要建一棵圣诞树,使得总的花费最小。具体规则是:圣诞树是一颗无向树形图,其中,编号为1的节点为根节点,原始图中每条边具有边权(unit):材料的单位价值;每个点也有一个权(weight):点的重量。生成树中,各条边的花费是该边权(unit)* 该边的子树中所有点的重量(weight)和,总的花费则是生成树中所有边的花费之和。
思路:1、在树中,两点的路径是唯一的
      2、对点u,只有从点u到根结点之间的边会乘以点u的重量
      3、点u的重量不变
      结论:最小总花费=每条边(u,v)*v的子树中各结点的重量
                      =每个点的重量*从该点到根结点的每条边的单位价值
                      =每个点*该点到根结点的最短路

代码:

#include<cstdio>
#include<queue>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long LL;
const LL N=50005;
const LL maxn=0xffffffff;
struct node{
    int now,next,w;
}str[2*N];
int n,m,a[N],head[2*N],vis[N];
LL d[N];
void spfa()
{
    queue<int>q;
    for(int i=1;i<=n;i++)
        d[i]=maxn;
    d[1]=0;
    q.push(1);
    while(q.size())
    {
        int zx=q.front();
        q.pop();
        vis[zx]=0;
        for(int i=head[zx];i!=-1;i=str[i].next)
        {
            int zy=str[i].now;
            if(d[zy]>d[zx]+str[i].w)
            {
                d[zy]=d[zx]+str[i].w;
                if(!vis[zy])
                    q.push(zy);
            }
        }
    }
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        memset(head,-1,sizeof(head));
        for(int i=1;i<=2*m;i+=2)
        {
            int x,y,w;
            scanf("%d%d%d",&x,&y,&w);
            str[i].now=y;
            str[i].w=w;
            str[i].next=head[x];
            head[x]=i;
            str[i+1].now=x;
            str[i+1].w=w;
            str[i+1].next=head[y];
            head[y]=i+1;
        }
        memset(vis,0,sizeof(vis));
        spfa();
        int flag=0;
        LL sum=0;
        for(int i=2;i<=n;i++)
        {
            if(d[i]==maxn)
            {
                flag=1;
                break;
            }
            sum+=a[i]*d[i];
        }
        if(flag)
            printf("No Answer\n");
        else
            printf("%I64d\n",sum);
    }
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值