poj 2392 Space Elevator (多重背包)

Description

The cows are going to space! They plan to achieve orbit by building a sort of space elevator: a giant tower of blocks. They have K (1 <= K <= 400) different types of blocks with which to build the tower. Each block of type i has height h_i (1 <= h_i <= 100) and is available in quantity c_i (1 <= c_i <= 10). Due to possible damage caused by cosmic rays, no part of a block of type i can exceed a maximum altitude a_i (1 <= a_i <= 40000). 

Help the cows build the tallest space elevator possible by stacking blocks on top of each other according to the rules.

Input

* Line 1: A single integer, K 

* Lines 2..K+1: Each line contains three space-separated integers: h_i, a_i, and c_i. Line i+1 describes block type i.

Output

* Line 1: A single integer H, the maximum height of a tower that can be built

Sample Input

3
7 40 3
5 23 8
2 52 6

Sample Output

48

Hint

OUTPUT DETAILS: 

From the bottom: 3 blocks of type 2, below 3 of type 1, below 6 of type 3. Stacking 4 blocks of type 2 and 3 of type 1 is not legal, since the top of the last type 1 block would exceed height 40.

Source



题意:有一头奶牛要上太空,他有很多种石头,每种石头的高度是hi,但是不能放到ai之上的高度,并且这种石头有ci个
将这些石头叠加起来,问能够达到的最高高度


思路:多重背包,其次a要按从小到大排序;

      设ai<aj,如果aj先放,ai有可能不能将aj的值叠加,因为它所限制的值小一些;

代码:

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int N=40005;
struct node{
    int h,a,c;
}str[N];
int dp[N];
bool cmp(node aa,node bb)
{
    return aa.a<bb.a;
}
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        for(int i=0;i<n;i++)
            scanf("%d%d%d",&str[i].h,&str[i].a,&str[i].c);
        memset(dp,0,sizeof(dp));
        sort(str,str+n,cmp);
        dp[0]=1;
        int maxx=0;
        for(int i=0;i<n;i++)
        {
            for(int j=str[i].a;j>=0;j--)
            {
                if(dp[j])
                {
                    for(int k=1;k<=str[i].c;k++)
                    {
                        int sum=j+k*str[i].h;
                        if(sum>str[i].a) continue;
                        dp[sum]=1;
                        if(maxx<sum)
                            maxx=sum;
                    }
                }
            }
        }
        printf("%d\n",maxx);
    }
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值