AcWing 3381:手机键盘

【题目来源】
https://www.acwing.com/problem/content/3384/

【题目描述】
请你计算按照手机键盘(9键输入法)输入字母的方式,键入给定字符串(由小写字母构成)所花费的时间。

具体键入规则和花费时间如下描述:
对于同一键上的字符,例如 a,b,c 都在 “1” 键上,输入 a 只需要按一次,输入 c 需要连续按三次。
如果连续两个字符不在同一个按键上,则可直接按,如:ad 需要按两下,kz 需要按 6 下。
如果连续两字符在同一个按键上,则两个按键之间需要等一段时间,如 ac,在按了 a 之后,需要等一会儿才能按 c。
现在假设每按一次需要花费一个时间段,等待时间需要花费两个时间段。

【输入格式】
输入包含多组测试数据。
每组数据占一行,包含一个由小写字母构成的字符串。

【输出格式】
对于每组输入,输出一行结果表示键入给定字符串所需要花费的时间。

【数据范围】
每个输入最多包含 100 组测试数据。
所有字符串的长度都不超过 100。

【输入样例】
bob
www

【输出样例】
7
7

【算法分析】
● 注意循环条件写为 while(cin>>str),不要写为 while(1) 之后且在其循环体中写 cin>>str,因为实践证明会 TLE。

【算法代码一】

#include <bits/stdc++.h>
using namespace std;

//The number of times to press the letter a~z
int cnt[]= {1,2,3,1,2,3,1,2,3,1,2,3,1,2,3,1,2,3,4,1,2,3,1,2,3,4};
//The key where the letter a~z is located
int at[]= {1,1,1,2,2,2,3,3,3,4,4,4,5,5,5,6,6,6,6,7,7,7,8,8,8,8};

string str;
int main() {
    while(cin>>str) {
        int ans=0;
        for(int i=0; i<str.size(); i++) {
            if(i>0 && at[str[i]-'a']==at[str[i-1]-'a']) ans+=2;
            ans+=cnt[str[i]-'a'];
        }
        cout<<ans<<endl;
    }
    return 0;
}

/*
in:
bob
www

out:
7
7
*/


【算法代码二:TLE
下面的写法超时了,TLE 。和上一个算法代码的差别在于将 cin>>str 写到 while 循环里了,同时循环条件写为 while(1)。

#include <bits/stdc++.h>
using namespace std;

//The number of times to press the letter a~z
int cnt[]= {1,2,3,1,2,3,1,2,3,1,2,3,1,2,3,1,2,3,4,1,2,3,1,2,3,4};
//The key where the letter a~z is located
int at[]= {1,1,1,2,2,2,3,3,3,4,4,4,5,5,5,6,6,6,6,7,7,7,8,8,8,8};

string str;
int main() {
    while(1) {
        int ans=0;
        cin>>str;
        for(int i=0; i<str.size(); i++) {
            if(i>0 && at[str[i]-'a']==at[str[i-1]-'a']) ans+=2;
            ans+=cnt[str[i]-'a'];
        }
        cout<<ans<<endl;
    }
    return 0;
}

/*
in:
bob
www

out:
7
7
*/



【参考文献】
https://www.acwing.com/solution/content/102126/
https://www.acwing.com/solution/content/124363/

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值