E - Quoit Design 平面分治

Have you ever played quoit in a playground? Quoit is a game in which flat rings are pitched at some toys, with all the toys encircled awarded. 
In the field of Cyberground, the position of each toy is fixed, and the ring is carefully designed so it can only encircle one toy at a time. On the other hand, to make the game look more attractive, the ring is designed to have the largest radius. Given a configuration of the field, you are supposed to find the radius of such a ring. 

Assume that all the toys are points on a plane. A point is encircled by the ring if the distance between the point and the center of the ring is strictly less than the radius of the ring. If two toys are placed at the same point, the radius of the ring is considered to be 0. 

Input

The input consists of several test cases. For each case, the first line contains an integer N (2 <= N <= 100,000), the total number of toys in the field. Then N lines follow, each contains a pair of (x, y) which are the coordinates of a toy. The input is terminated by N = 0. 

Output

For each test case, print in one line the radius of the ring required by the Cyberground manager, accurate up to 2 decimal places. 

Sample Input

2
0 0
1 1
2
1 1
1 1
3
-1.5 0
0 0
0 1.5
0

Sample Output

0.71
0.00
0.75

题意

     求最近的两点之间的距离的一半

思路

    很典型的平面分治问题,将坐标平面一分为二,左右两平面各自找出距离最近的点d,再找出分线附近距离小于d的最小的两点距离,

那么左平面内的坐标距离如何算呢,当然还是分割为左右平面了,直至达到临界点,只剩下两个坐标或一个坐标。这么一说,很像二叉树的样子。

 

 1
 2
 3
 4
 5
 6
 7
 8
 9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<vector>
#include<queue>
#include<stack>
#include<string>
#define long long LL
#define INF 0x3f3f3f3f
#define PI acos(-1.0)
#define lson o<<1
#define rson o<<1|1
using namespace std;
struct node{
	double x, y;
}a[100005];
double Min(double x, double y)
{
	if(x > y)
		return y;
	return x;
}
bool cmpx(node a, node b)
{
	return a.x < b.x;
}
bool cmpy(node l, node r)
{
	return l.y < r.y;
}
double Cal_dis(node c, node d)   
{
	return sqrt((c.x - d.x) * (c.x - d.x) + (c.y - d.y) * (c.y - d.y));
}
double Short_dis(int l, int r)
{
	double d = 10000;
	if(l == r)    // 临界点,若为一个坐标,返回 inf
		return d;
	else if(l + 1 == r)    // 临界点,返回两点间的距离
		return Cal_dis(a[l], a[r]);
	int mid = (l + r) >> 1;
	d = Min(Short_dis(l, mid), Short_dis(mid + 1, r));    // 类似二叉树,分成左右两平面,取最小
	int i = l, j = r;
	while(i < mid && a[mid].x - a[i].x >=d) i++;  // 若横坐标距离不小于d,更别提两点距离了
	while(j > mid && a[j].x - a[mid].x >=d) j--;  // 分割线附近满足条件的点
	sort(a + i + 1, a + j + 1, cmpy); // 只有当横坐标小于d,纵坐标也小于d时,
                                         //两点距离才有可能小于d
	for(int k = i; k <= j; k++)
	{
		for(int m = k + 1;m <= j && a[m].y - a[k].y < d; m++)
		{
			double D = Cal_dis(a[m], a[k]);
			if(d > D)
				d = D;
		}
	}
	return d; 
}
int main()
{
	int N;
	while(cin >> N && N)
	{
		for(int i = 1; i <= N; i++)
			scanf("%lf %lf", &a[i].x, &a[i].y);
		sort(a + 1, a + N + 1, cmpx);  //  先按横坐标从小达大排列
		double ans = Short_dis(1, N);
		printf("%.2lf\n", ans/2);
	}

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值