平面的分治与归并

poj-3714-Raid

After successive failures in the battles against the Union, the Empire retreated to its last stronghold. Depending on its powerful defense system, the Empire repelled the six waves of Union’s attack. After several sleepless nights of thinking, Arthur, General of the Union, noticed that the only weakness of the defense system was its energy supply. The system was charged by N nuclear power stations and breaking down any of them would disable the system.

The general soon started a raid to the stations by N special agents who were paradroped into the stronghold. Unfortunately they failed to land at the expected positions due to the attack by the Empire Air Force. As an experienced general, Arthur soon realized that he needed to rearrange the plan. The first thing he wants to know now is that which agent is the nearest to any power station. Could you, the chief officer, help the general to calculate the minimum distance between an agent and a station?

Input
The first line is a integer T representing the number of test cases.
Each test case begins with an integer N (1 ≤ N ≤ 100000).
The next N lines describe the positions of the stations. Each line consists of two integers X (0 ≤ X ≤ 1000000000) and Y (0 ≤ Y ≤ 1000000000) indicating the positions of the station.
The next following N lines describe the positions of the agents. Each line consists of two integers X (0 ≤ X ≤ 1000000000) and Y (0 ≤ Y ≤ 1000000000) indicating the positions of the agent.  

Output
For each test case output the minimum distance with precision of three decimal placed in a separate line.

Sample Input
2
4
0 0
0 1
1 0
1 1
2 2
2 3
3 2
3 3
4
0 0
0 0
0 0
0 0
0 0
0 0
0 0
0 0
Sample Output
1.414
0.000
大意:就是t组样例,第二行输入n,接下来n行输入n个坐标,再输入n个坐标,分成两组,让你找出两组之中相距最近的两个点的距离。
思路:由于n比较大暴力肯定是TLE的,那就用平面的分治与归并找最小距离,不过这个题是分成两组来考虑,可以在结构体中加入一个参数来把坐标分成两组,计算距离的时候判断是不是两个点分别在这两组之中就行了。
这个题在poj中wa了很多次,居然是G++的问题,换了C++就ac了,都是泪啊!!

#include<stdio.h>
#include<math.h>
#include<algorithm>
using namespace std;
const double oo = 1e50;
struct stu{
    double x,y;
    int id;
}de[200050];
bool cmp(stu a,stu b)  //排序
{
    return a.x < b.x;
}
double dist(stu a,stu b)
{
    if(a.id == b.id) return oo;   //当是同一组的两个点时,返回距离无穷大
    return sqrt((a.x-b.x)*(a.x-b.x) + (a.y-b.y)*(a.y-b.y));
}
double solve(int l,int r)
{
    double d;
    if(l == r)    //两个特判
        return oo;
    else if(l + 1 == r)
        return dist(de[l],de[r]);
    int mid = (l + r) >> 1;
    double st = de[mid].x;
    d = min(solve(l,mid), solve(mid+1,r));  //找到分成多个平面中两个面里的点的最近距离

    for(int i = mid;i >= l && st - de[i].x < d; i--)//在中轴线mid周围2d的区域筛选出距离最小的两个点
        for(int j = mid+1;j <= r && de[j].x - st < d; j++)
            d = min(d, dist(de[i],de[j]));
    return d;   
}

int main()
{
    int t,n,i;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(i = 0; i < n; i++){
            scanf("%lf%lf",&de[i].x,&de[i].y);
            de[i].id = 0;
        }
        for(; i < 2*n; i++){
            scanf("%lf%lf",&de[i].x,&de[i].y);
            de[i].id = 1;
        }
        sort(de,de+n+n,cmp);
        printf("%.3lf\n",solve(0,2*n-1));
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值