3984 迷宫问题 BFS入门题+记录路径

迷宫问题
Time Limit: 1000MS      Memory Limit: 65536K
Total Submissions: 14106        Accepted: 8415
Description
定义一个二维数组: 

int maze[5][5] = {

    0, 1, 0, 0, 0,

    0, 1, 0, 1, 0,

    0, 0, 0, 0, 0,

    0, 1, 1, 1, 0,

    0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
Input
一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
Output
左上角到右下角的最短路径,格式如样例所示。
Sample Input
0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
Sample Output
(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)
Source
[Submit]   [Go Back]   [Status]   [Discuss]

来源: http://poj.org/problem?id=3984
        Source Code
        Problem: 3984       
        Memory: 176K        Time: 0MS
        Language: C++       Result: Accepted
#include <iostream>
#include <cstring>
#include <cstdio>
#include <queue>
using namespace std;
typedef struct
{int I,J,step;}Point;
typedef struct
{int laI,laJ;}Map;
Map MAP[7][7];
int maze [7][7];
bool visit[7][7];
int MoveI[5]={0,1,0,-1,0};  //精简代码
int MoveJ[5]={0,0,1,0,-1}; //精简代码
void Handle(void)
{
    for(int i=1;i<=5;i++)
        for(int j=1;j<=5;j++) scanf("%d",&maze[i][j]);
    for(int i=1;i<=5;i++) maze[6][i]=maze[0][i]=maze[i][0]=maze[i][6]=-1;///边界
}
int BFS(void)
{
    memset(visit,false,sizeof(visit));
    Point P,Q;P.I=P.J=1;P.step=1;MAP[1][1].laI=MAP[1][1].laJ=0;
    queue<Point> bfs;bfs.push(P);
    while(!bfs.empty())
    {
        P = bfs.front();
        if(P.I==5&&P.J==5) return P.step;
        P.step++;
        for(int k=1;k<=4;k++)
        {
            Q = P;Q.I+=MoveI[k];Q.J+=MoveJ[k];
            if(maze[Q.I][Q.J]==0&&!visit[Q.I][Q.J])
            {
                MAP[Q.I][Q.J].laI=P.I;
                MAP[Q.I][Q.J].laJ=P.J;
                visit[Q.I][Q.J] = true;
                bfs.push(Q);
            }
        }
        bfs.pop();
    }
    return 0;
}
void print(int i,int j)
{
    if(i==1&&j==1) printf("(0, 0)\n");
    else
    {
        print(MAP[i][j].laI,MAP[i][j].laJ);
        printf("(%d, %d)\n",i-1,j-1);
    }
}
int main(void)
{
    Handle();BFS();
    print(5,5);
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值