B - Conic Section 很水的判断题

B - Conic Section
Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu
SubmitStatusPracticeZOJ 3488
Description
The conic sections are the nondegenerate curves generated by the intersections of a plane with one or two nappes of a cone. For a plane perpendicular to the axis of the cone, a circle is produced. For a plane that is not perpendicular to the axis and that intersects only a single nappe, the curve produced is either an ellipse or a parabola. The curve produced by a plane intersecting both nappes is a hyperbola.

conic section   equation
circle  x2+y2=a2
ellipse x2/a2+y2/b2=1
parabola    y2=4ax
hyperbola   x2/a2-y2/b2=1
Input
There are multiple test cases. The first line of input is an integer T ≈ 10000 indicating the number of test cases.
Each test case consists of a line containing 6 real numbers a, b, c, d, e, f. The absolute value of any number never exceeds 10000. It's guaranteed that a2+c2>0, b=0, the conic section exists and it is non-degenerate.
Output
For each test case, output the type of conic section ax2+bxy+cy2+dx+ey+f=0. See sample for more details.
Sample Input
5
1 0 1 0 0 -1
1 0 2 0 0 -1
0 0 1 1 0 0
1 0 -1 0 0 1
2 0 2 4 4 0
Sample Output
circle
ellipse
parabola
hyperbola
circle
References

Weisstein, Eric W. "Conic Section." From MathWorld--A Wolfram Web Resource. http://mathworld.wolfram.com/ConicSection.html
来源: http://acm.hust.edu.cn/vjudge/contest/view.action?cid=118191#problem/B
#include <bits/stdc++.h>
using namespace std;
int main()
{
    //freopen("F:\\test.txt","r",stdin);
    int T;cin>>T;double a,b,c,d,e,f;
    for(int i=1;i<=T;i++)
    {
        scanf("%lf %lf %lf %lf %lf %lf ",&a,&b,&c,&d,&e,&f);
        double M = d*d/4/a,N = e*e/4/c;
        double A = a/(M+N-f),B = c/(M+N-f);
        if(a==0||c==0) printf("parabola\n");///单二次
        else if(A*B>0)///2.同号
        {
            if(A==B&&(A)*(M+N-f)>0) printf("circle\n");//!
            else printf("ellipse\n");
        }
        else if(A*B<0) printf("hyperbola\n");
    }
    return 0;
}

来源: http://acm.hust.edu.cn/vjudge/contest/viewSource.action?id=6159671

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值