HDU 2669 Romantic 扩展欧几里得裸题 有不理解的地方

Romantic
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4304    Accepted Submission(s): 1808


Problem Description
The Sky is Sprite.
The Birds is Fly in the Sky.
The Wind is Wonderful.
Blew Throw the Trees
Trees are Shaking, Leaves are Falling.
Lovers Walk passing, and so are You. 
................................Write in English class by yifenfei



Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem!
Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead.


Input
The input contains multiple test cases.
Each case two nonnegative integer a,b (0<a, b<=2^31)


Output
output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put "sorry" instead. 


Sample Input
77 51
10 44
34 79


Sample Output
2 -3
sorry
7 -3


Author
yifenfei


Source
HDU女生专场公开赛——谁说女子不如男


Recommend
lcy   |   We have carefully selected several similar problems for you:  2668 2674 2671 2670 2672 

来源: http://acm.hdu.edu.cn/showproblem.php?pid=2669

//!  设次数为ans  :     (ans*m+x)- (ans*n+y) = L*times
//!  --> ans*(m-n) + (-L)*times = y - x
#include <iostream>
#include <cstdio>
#include <cmath>
typedef long long LL;
using namespace std;
void exgcd(LL a,LL b,LL &x,LL &y,LL &d)
{
    if(!b) { d=a; x=1; y=0;}
    else {exgcd(b,a%b,y,x,d);y-=x*(a/b);}
}
int Cal(LL a,LL b,LL c)    -->可以得到ax+by = c的最小正整数x  而y = (c-x*a)/b;
{//!获得最小的x解
    LL x,y,gcd;exgcd(a,b,x,y,gcd);
    if(c%gcd) return -1;
    x*=c/gcd;b/=gcd;
    if(b<0) b=-b;
    LL ans=x%b;
    return ans<=0?ans+b:ans;
}

int main(void)
{
   // freopen("D:\\test.txt","r",stdin);
    LL a,b;
    while(cin>>a>>b)
    {
        LL ans = Cal(a,b,1);  //为什么要化为1元求    -->ax+by=c  此处c=1
        if(ans==-1) cout<<"sorry"<<endl; 
        else printf("%I64d %I64d\n",ans,(1-ans*a)/b);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值