传送门:Romantic
Romantic
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 2592 Accepted Submission(s): 1025
Problem Description
The Sky is Sprite.
The Birds is Fly in the Sky.
The Wind is Wonderful.
Blew Throw the Trees
Trees are Shaking, Leaves are Falling.
Lovers Walk passing, and so are You.
................................Write in English class by yifenfei
Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem!
Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead.
The Birds is Fly in the Sky.
The Wind is Wonderful.
Blew Throw the Trees
Trees are Shaking, Leaves are Falling.
Lovers Walk passing, and so are You.
................................Write in English class by yifenfei
Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem!
Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead.
Input
The input contains multiple test cases.
Each case two nonnegative integer a,b (0<a, b<=2^31)
Each case two nonnegative integer a,b (0<a, b<=2^31)
Output
output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put "sorry" instead.
Sample Input
77 51 10 44 34 79
Sample Output
2 -3 sorry 7 -3
Author
yifenfei
Source
解题报告:
题中只需要求解a*x+b*y=1,a和b互质gcd(a,b)=1,这是基础情况,先想办法求解这个方程(a,b已知,x,y未知),把这个题目理解了再去求变形一点点的情况a*x+b*y=n,n是gcd(a,b)的倍数,n也可能不是1。
代码如下:
#include<iostream>
#include<cstdio>
using namespace std;
int ext_gcd(int a,int b,int &x,int &y){
if(b==0){
x=1;y=0; return a;
}
int d=ext_gcd(b,a%b,x,y);
int xt=x;
x=y;
y=xt-a/b*y;
return d;
}
int main(){
int a,b;
while(scanf("%d%d",&a,&b)==2){
int x,y;
int d=ext_gcd(a,b,x,y);
if(d!=1)
printf("sorry\n");
else{
int tx;
tx=x;
x=(x%b+b)%b;
y=y-(x-tx)/b*a;
printf("%d %d\n",x,y);
}
}
return 0;
}