题目学习——HDUOJ-2669




Romantic

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Problem Description
Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead.
 

Input
The input contains multiple test cases.
Each case two nonnegative integer a,b (0<a, b<=2^31)
 

Output
output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put "sorry" instead. 
 

Sample Input
  
  
77 51 10 44 34 79
 

Sample Output
  
  
2 -3 sorry 7 -3
 

Author
yifenfei


#include <iostream>
#include <cstdio>
#define LL long long int
using namespace std;

LL e_gcd(LL a,LL b,LL &x,LL &y)
{
    if(b==0){
        x=1;
        y=0;
        return a;
    }
    LL ans=e_gcd(b,a%b,x,y);
    LL temp=x;
    x=y;
    y=temp-a/b*y;
    return ans;
}
LL inv(LL a,LL m,LL c)
{
    LL x,y;
    LL gcd=e_gcd(a,m,x,y);
    if(c%gcd!=0)return -1;
    m=c/gcd*m;
    if(m<0)m=-m;
    LL ans=x%m;
    if(ans<=0)ans=ans+m;
    return ans;
}


int main()
{
    LL a,b,x,y,ans;
    while(scanf("%lld%lld",&a,&b)!=EOF){
        if((ans=inv(a,b,1))!=-1)printf("%lld %lld\n",ans,(1-ans*a)/b);
        else printf("sorry\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值