HDU 1325 Is It A Tree 并查集+树的性质

11 篇文章 0 订阅
Is It A Tree?
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 21241    Accepted Submission(s): 4807


Problem Description
A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 
There is exactly one node, called the root, to which no directed edges point. 

Every node except the root has exactly one edge pointing to it. 

There is a unique sequence of directed edges from the root to each node. 

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.

这里写图片描述 这里写图片描述 这里写图片描述

In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not. 



Input
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero. 


Output
For each test case display the line ``Case k is a tree." or the line ``Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1). 


Sample Input
6 8 5 3 5 2 6 4
5 6 0 0
8 1 7 3 6 2 8 9 7 5
7 4 7 8 7 6 0 0
3 8 6 8 6 4
5 3 5 6 5 2 0 0
-1 -1


Sample Output
Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.

和小希的迷宫相似,但是是一颗树,要求除根结点(必须有一个入度为0)外都得是入度为1
只要外加一个检索表,最后判断一下就可以
要注意的是空树也是树,数据 只有结尾 0 0也是对的

#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;
#define MAXN 100000
bool room[MAXN * 2];//房间是不连续的
inline int MAX3(int a, int b, int c) { return max(a, max(b, c)); }
int Par[MAXN * 2], Rank[MAXN * 2];
bool In[MAXN * 2];
void Init(int n)
{
    for (int i = 1;i <= n;i++)
    {
        Par[i] = i;
        Rank[i] = 0;
    }
}
int Find(int x)
{
    if (Par[x] == x) return x;
    else return Par[x] = Find(Par[x]); ///同时压缩路径
}
void Unite(int x, int y)
{
    x = Find(x);y = Find(y);
    if (x == y) return;
    if (Rank[x]<Rank[y]) Par[x] = y;
    else Par[y] = x;
    if (Rank[x] == Rank[y]) Rank[x]++;
}
int main(void)
{
    //freopen("F:\\test.txt","r",stdin);
    int a, b, flag = 1,Count = 0;Init(100500);
    int Max = -1;memset(room, 0, sizeof(room));
    while (~scanf("%d %d", &a, &b))
    {
        if (a < 0&& b < 0) break;
        if (a || b)
        {
            In[b]++;
            if (!room[a]) room[a] = true;
            if (!room[b]) room[b] = true;
            Max = MAX3(a, b, Max);
            if (Par[a] != Par[b]) Unite(a, b);
            else if (a != b) flag = 0;
        }
        else
        {
            int Only = 0,is_None = 1;
            for (int i = 1, Father = 0;i <= Max;i++)
            {
                if(room[i]) is_None = 0;
                if (!Father&&room[i]) Father = Find(i);        
                if (room[i] && Find(i) != Father) { flag = 0;break; }//祖先应当是同一个(根结点)
                if (room[i] && In[i] == 0) Only ++;
                else if (room[i] && In[i] >= 2) flag = 0;
            }
            if(is_None) {flag = 1;Only = 1;}
            printf("Case %d %s\n",++Count,flag&& Only ==1?"is a tree." : "is not a tree.");
            flag = 1;Init(100500);
            Max = -1;memset(room, 0, sizeof(room));
            memset(In, 0, sizeof(In));
        }
    }
}

来源: http://acm.hdu.edu.cn/showproblem.php?pid=1325

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值