HDU 2579 Dating with girls(2) BFS 又一种新的搜索类型 很好的题

Dating with girls(2)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1418    Accepted Submission(s): 393


Problem Description
If you have solved the problem Dating with girls(1).I think you can solve this problem too.This problem is also about dating with girls. Now you are in a maze and the girl you want to date with is also in the maze.If you can find the girl, then you can date with the girl.Else the girl will date with other boys. What a pity!
The Maze is very strange. There are many stones in the maze. The stone will disappear at time t if t is a multiple of k(2<= k <= 10), on the other time , stones will be still there.
There are only ‘.’ or ‘#’, ’Y’, ’G’ on the map of the maze. ’.’ indicates the blank which you can move on, ‘#’ indicates stones. ’Y’ indicates the your location. ‘G’ indicates the girl's location . There is only one ‘Y’ and one ‘G’. Every seconds you can move left, right, up or down.
 

Input
The first line contain an integer T. Then T cases followed. Each case begins with three integers r and c (1 <= r , c <= 100), and k(2 <=k <= 10).
The next r line is the map’s description.
 

Output
For each cases, if you can find the girl, output the least time in seconds, else output "Please give me another chance!".
 

Sample Input
  
  
1 6 6 2 ...Y.. ...#.. .#.... ...#.. ...#.. ..#G#.
 

Sample Output
  
  
7
 

Source
 

Recommend
lcy
 
题意:
  从 Y到G  问最短的路程是什么  其中 .为可走路径 #为石头 其中石头在时间%k==0的时候是可以消失的 即使可以走的     如果不等于0 就会又出现
 
思路:
这样一个路径可能走过一次了 还要再走 因为可能一开始石头在 后来石头不在了
 
在时间能被k整除的时候障碍会消失,这样就需要在一般的二维迷宫判重数组上加上一维。这一维的意义是总时间模k的余数 这样来表示一种状态
vis[i][j][t]的意义是总时间模k余t时在x,y。因为一个格子上不同的时间余数代表不同的状态,在这些状态下扩展出的节点可能不同,所以需要三维判重
 
 
#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
int n,m,k,sx,sy,ex,ey;
struct haha
{
    int x, y, step;
}q,temp;
char map[111][111];
int dir[4][2]={0,1,0,-1,1,0,-1,0};
int vis[111][111][11];
void BFS()
{
    int i;
    q.x=sx;
    q.y=sy;
    q.step=0;
    queue<struct haha>que;
    memset(vis,0,sizeof(vis));
    vis[sx][sy][0]=1;
    que.push(q);
    while(!que.empty())
    {
        temp=que.front();
        que.pop();
        if(temp.x==ex&&temp.y==ey)
        {
            printf("%d\n",temp.step);
            return ;
        }
        for(i=0;i<4;i++)
        {
            int xx,yy;
            xx=temp.x+dir[i][0];
            yy=temp.y+dir[i][1];
            if(xx>=0&&xx<n&&yy>=0&&yy<m&&(map[xx][yy]!='#'||(temp.step+1)%k==0)&&!vis[xx][yy][(temp.step+1)%k])
            {
                q.step=temp.step+1;
                q.x=xx;
                q.y=yy;
                vis[xx][yy][(temp.step+1)%k]=1;
                que.push(q);
            }
        }
    }
    printf("Please give me another chance!\n");
}
int main()
{
    int i,j,cas;
    scanf("%d",&cas);
    while(cas--)
    {
        scanf("%d %d %d",&n,&m,&k);
        for(i=0;i<n;i++)
        {
            scanf("%s",map[i]);
            for(j=0;j<m;j++)
            {
                if(map[i][j]=='Y')  {sx=i;sy=j;}
                else if(map[i][j]=='G') {ex=i;ey=j;}
            }
        }
        BFS();
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值