Dating with girls(2) (bfs)

If you have solved the problem Dating with girls(1).I think you can solve this problem too.This problem is also about dating with girls. Now you are in a maze and the girl you want to date with is also in the maze.If you can find the girl, then you can date with the girl.Else the girl will date with other boys. What a pity! 
The Maze is very strange. There are many stones in the maze. The stone will disappear at time t if t is a multiple of k(2<= k <= 10), on the other time , stones will be still there. 
There are only ‘.’ or ‘#’, ’Y’, ’G’ on the map of the maze. ’.’ indicates the blank which you can move on, ‘#’ indicates stones. ’Y’ indicates the your location. ‘G’ indicates the girl's location . There is only one ‘Y’ and one ‘G’. Every seconds you can move left, right, up or down. 

Input

The first line contain an integer T. Then T cases followed. Each case begins with three integers r and c (1 <= r , c <= 100), and k(2 <=k <= 10). 
The next r line is the map’s description.

Output

For each cases, if you can find the girl, output the least time in seconds, else output "Please give me another chance!".

Sample Input

1
6 6 2
...Y..
...#..
.#....
...#..
...#..
..#G#.

Sample Output

7

题意:给了一个图,求从Y到G的最短时间,不过给了一个k,同时遇见 ‘#’ 如果用时是k的倍数时,# 消失;

思路:和平常bfs差不多,不过book数组用三维数组来标记,即位置(x,y),以及走到这里用的时间对k取模。同时yu遇到 # 的时候需要判断时间是否能整除k。

代码如下:

#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
int n,m,t,book[110][110][11],dir[4][2]={0,1,1,0,0,-1,-1,0};
char str[110][110];
struct node
{
    int x,y,n;
    bool operator < (const node &a)const  //最短时间放在队首
    {
        return a.n<n;
    }
};
void bfs(int x,int y)
{
    memset(book,0,sizeof(book));
    priority_queue<node>Q;
    node q,p;
    q.x=x;
    q.y=y;
    q.n=0;
    book[x][y][0]=1;
    Q.push(q);
    while(!Q.empty())
    {
        p=Q.top();
        Q.pop();
        for(int i=0;i<4;i++)
        {
            int xx=p.x+dir[i][0];
            int yy=p.y+dir[i][1];
            if(xx<0||yy<0||xx>=n||yy>=m)
                continue;
            q.x=xx;
            q.y=yy;
            q.n=p.n+1;
            if(str[q.x][q.y]=='G')
            {
                printf("%d\n",q.n);
                return;
            }
            if(str[xx][yy]=='#'&&q.n%t)  //时间需能整除t
                continue;
            int tt=q.n%t;
            if(book[xx][yy][tt])
                continue;
            book[xx][yy][tt]=1;
            Q.push(q);
        }
    }
    printf("Please give me another chance!\n");
}
int main()
{
    int tt;
    scanf("%d",&tt);
    while(tt--)
    {
        scanf("%d%d%d",&n,&m,&t);
        int ex,ey;
        for(int i=0;i<n;i++)
        {
            scanf("%s",str[i]);
            for(int j=0;j<m;j++)
            {
                if(str[i][j]=='Y')
                {
                    ex=i;
                    ey=j;
                }
            }
        }
        bfs(ex,ey);
    }
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值