Dating with girls(2)

If you have solved the problem Dating with girls(1).I think you can solve this problem too.This problem is also about dating with girls. Now you are in a maze and the girl you want to date with is also in the maze.If you can find the girl, then you can date with the girl.Else the girl will date with other boys. What a pity!
The Maze is very strange. There are many stones in the maze. The stone will disappear at time t if t is a multiple of k(2<= k <= 10), on the other time , stones will be still there.
There are only ‘.’ or ‘#’, ’Y’, ’G’ on the map of the maze. ’.’ indicates the blank which you can move on, ‘#’ indicates stones. ’Y’ indicates the your location. ‘G’ indicates the girl's location . There is only one ‘Y’ and one ‘G’. Every seconds you can move left, right, up or down.

Input

The first line contain an integer T. Then T cases followed. Each case begins with three integers r and c (1 <= r , c <= 100), and k(2 <=k <= 10).
The next r line is the map’s description.

Output

For each cases, if you can find the girl, output the least time in seconds, else output "Please give me another chance!".

Sample Input

1
6 6 2
...Y..
...#..
.#....
...#..
...#..
..#G#.

Sample Output

7

约会女孩,一看这道题就来了感觉,但是刚开始还是无从下手的,这个一个地点他能来回走,那么我到底标记还是不标记,这个还是得标记但是,利用三维数组来标记,而他的第三项储存的时间需要管理一下,如果能够整除K的话,那么就说明是可以到达这个地方的,其余的地方还是广搜的样子。

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<queue>
using namespace std;
int n,m,k;
char a[110][110];;
int  book[1010][110][20],w[4][2]={1,0,-1,0,0,1,0,-1};
struct node
{
    int x,y;
    int step;
} s,e;
int cn(int x,int y,int z)
{
    if(x>n||x<=0||y>m||y<=0||book[x][y][z%k])
        return 0;
    if(a[x][y]=='#')
    {
        if(z%k==0)
            return 1;
        return 0;
    }
    return 1;
}
int bfs()
{
    memset(book,0,sizeof(book));
    queue<node>q;
    node st,en;
    book[s.x][s.y][0] = 1;
    s.step = 0;
    q.push(s);
    while(!q.empty())
    {
        st=q.front();
        q.pop();
        for(int i=0; i<4; ++i)
        {
            en.x=st.x+w[i][0];
            en.y=st.y+w[i][1];
            en.step = st.step+1;
            if(cn(en.x,en.y,en.step))
            {
                if(en.x==e.x&&en.y==e.y)
                    return en.step;
                book[en.x][en.y][en.step%k]=1;
                q.push(en);
            }
        }
    }
    return -1;
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d%d",&n,&m,&k);
        getchar();
        for(int i=1; i<=n; ++i)
        {
            for(int j=1; j<=m; ++j)
            {
                scanf("%c",&a[i][j]);
                if(a[i][j]=='G')
                {
                    e.x=i;
                    e.y=j;
                }
                else if(a[i][j]=='Y')
                {
                    s.x=i,s.y=j;
                }
            }
            getchar();
        }
        int sum=bfs();
        if(sum==-1)
            printf("Please give me another chance!\n");
        else
        printf("%d\n",sum);
    }
    return 0;
}
 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值