MaxinumFlowProblem(最大流)

FlowProbleam

Problem Description

Network flow is a well-known difficult problem for ACMers. Given a graph, your task is to find out the maximum flow for the weighted directed graph.

Input

The first line of input contains an integer T, denoting the number of test cases.
For each test case, the first line contains two integers N and M, denoting the number of vertexes and edges in the graph. (2 <= N <= 15, 0 <= M <= 1000)
Next M lines, each line contains three integers X, Y and C, there is an edge from X to Y and the capacity of it is C. (1 <= X, Y <= N, 1 <= C <= 1000)

Output

For each test cases, you should output the maximum flow from source 1 to sink N.

Sample Input

2

3 2

1 2 1

2 3 1

3 3

1 2 1

2 3 1

1 3 1

Sample Output

Case 1: 1

Case 2: 2

解题思路

           最简单的最大流问题,寻找出所有的增广路径计算出总流量即可。

          增广路算法:对于源点s和汇点t,如果存在一条路径满足最小的流量d>0,那么就是一条增广路径,对于该路径上的所有边可以进行一次增广,即对于该路径上的所有边,该边的流量减少d,由斜对称性,对应的相反边流量增加d。采用刘汝佳老师的紫书模板进行求解,

解题代码

#include <iostream>
#include<algorithm>
#include<cstring>
#include<queue>
#include<vector>
#define rep(i,s,e) for(int i =s ;i<e;i++)
using namespace std;
const int maxn = 50;
const int  INF = 2000000;
int t;
int n,m;
struct Edge{
    int from , to , cap,flow;
    Edge(int u,int v,int c,int f): from(u),to(v),cap(c),flow(f){}
};
//增光路算法
struct EdomdsKarp{
    int n,m;
    vector<Edge> edges;
    vector<int>  G[maxn];//邻接表存储图
    int a[maxn];//起点到i的可以改进量
    int p[maxn];//最短路树上p的入弧编号

    void init(int n){
        rep(i,0,n) G[i].clear();
    }

    //添加边并添加斜对称边
    void AddEdge(int from,int to,int cap){
        edges.push_back(Edge(from,to,cap,0));
        edges.push_back(Edge(to,from,0,0));
        m = edges.size();
        G[from].push_back(m-2);
        G[to].push_back(m-1);
    }

    int maxFlow(int s,int t){
        long long flow = 0 ;
        while(1){
            memset(a,0,sizeof(a));
            queue<int> q;
            q.push(s);
            a[s] = INF;
            while(!q.empty()){
                int x = q.front(); q.pop();
                int len = G[x].size();
                rep(i,0,len){
                    Edge& e = edges[G[x][i]];
                    if(!a[e.to]&&e.cap > e.flow){
                        p[e.to] = G[x][i];
                        a[e.to] = min(a[x],e.cap-e.flow);
                        q.push(e.to);
                    }
                }
                if(a[t]) break;//此时已经找到了一条增广路径
            }
            if(!a[t]) break;
            for(int u = t;u!=s; u =edges[p[u]].from){
                edges[p[u]].flow +=a[t];
                edges[p[u]^1].flow -=a[t];
            }
            flow+=a[t];
        }
        return flow;
    }
};
int main()
{
    cin>>t;
    int ct = 1;
    while(t--){
        int n,m;
        cin>>n>>m;
        EdomdsKarp ek;
        ek.init(n);
        rep(i,0,m){
            int u,v,c;
            cin>>u>>v>>c;
            ek.AddEdge(u-1,v-1,c);
        }
        cout<<"Case "<<ct++<<": "<<ek.maxFlow(0,n-1)<<endl;
        //if(t!=0) cout<<endl;
    }
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值