poj 2386 Lake counting

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

Hint

OUTPUT DETAILS: 

There are three ponds: one in the upper left, one in the lower left,and one along the right side.

Source


这代码是挑战程序设计竞赛里的一份例题,代码思路也是按照书上的写的

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int n,m;
char st[102][102];
int dir[8][2]= {{0,1},{0,-1},{1,0},{-1,0},{1,-1},{1,1},{-1,-1},{-1,1}};

void dfs(int x,int y) {
    st[x][y]='.';
    for(int i=0; i<8; i++) {
        int newx=x+dir[i][0];
        int newy=y+dir[i][1];
        if(newx>=0 && newx <n && newy>=0 && newy <m && st[newx][newy]=='W') {
            dfs(newx,newy);
        }
    }
    return ;
}


int main() {
    scanf("%d%d",&n,&m);
    int ans=0;
    for(int i=0; i<n; i++)
        for(int j=0; j<m; j++)
            scanf(" %c",&st[i][j]);
    for(int i=0; i<n; i++)
        for(int j=0; j<m; j++)
            if(st[i][j]=='W') {
                dfs(i,j);
                ans++;
            }
    printf("%d\n",ans);
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值