Axis入门(2)

原创 2004年07月31日 14:23:00

怎么安装Axis

1)安装JDK1.3版或以上
我的是D:/j2sdk1.4.2
2)安装TOMCAT5.0
不一定要求是TOMCAT,只要是支持servlet 2.2 API的就可以;我的是D:/Tomcat 5.0
TOMCAT启动应该不报错.
3)下载axis1.1版
http://xml.apache.org下载,解压,我的是D:/axis/axis-1_1
4)拷贝axis
从D:/axis/axis-1_1/webapps/axis copy to D:/Tomcat 5.0/webapps/axis
5)建立包文件
如果你的JDK版本大于1.4,则不需要XML PARSER的包了;否则,请找到xerces包,放到D:/Tomcat 5.0/webapps/axis/WEB-INF/lib目录
6)启动TOMCAT,访问http://127.0.0.1:8080/axis/,应该出现Apache-Axis启动页面.
7)点选Validate,应该报错,如下:
Error: could not find class javax.activation.DataHandler from file activation.jar
Axis will not work
See http://java.sun.com/products/javabeans/glasgow/jaf.html
Optional Components
Warning: could not find class javax.mail.internet.MimeMessage from file mail.jar
Attachments will not work
See http://java.sun.com/products/javamail/
ERROR中提到的包是应该放到相应目录的,Optional Components是可选的包.
8)我们观察,D:/Tomcat 5.0/webapps/axis目录下有个EchoHeader.jws文件,我们可以用它来测试JWS服务,访问 http://localhost:8080/axis/EchoHeaders.jws?method=list我们可以看到效果.

?

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/hongbo781202/article/details/57249

webservices系列(四)——Axis2入门框架

一.Axis2下载 1.从http://axis.apache.org/axis2/java/core/download.html下载Axis2最新版本: 可以下载如下两个zip包: axis2-1....
  • luo4105
  • luo4105
  • 2017-04-10 12:26:58
  • 3837

tf.argmax()中的axis参数

tf.argmax()中的axis在等于0时,按列比较,取得最大值的下标索引;等于1时,按行比较。...
  • cx1425924660
  • cx1425924660
  • 2017-08-23 14:21:50
  • 249

numpy模块中的sum(axis)方法

1、sum函数声明sum(a, axis=None, dtype=None, out=None, keepdims=)参数axis究竟是用来干嘛的?2、实验经过我的一些尝试,我发现以下规律:(1) ...
  • flyawayl
  • flyawayl
  • 2017-12-31 21:21:07
  • 304

Axis实例,Axis

  • 2010年05月11日 07:51
  • 685KB
  • 下载

numpy.append() 里的axis的用法

如果你看完这篇东西,做出来遇到错误,欢迎咨询QQ:214516448,有偿帮你远程解决各种配置环境的error,解决速度超级快。def append(arr, values, axis=None): ...
  • qq_35019361
  • qq_35019361
  • 2018-01-14 12:51:55
  • 740

AXIS简单实现入门

http://localhost/serviceshttp://localhost/servlet/AdminServlet l         至 http://ws.apache.org/axis...
  • vcvj
  • vcvj
  • 2004-09-15 12:01:00
  • 3470

Axis入门(2)

怎么安装Axis 1)安装JDK1.3版或以上我的是D:/j2sdk1.4.22)安装TOMCAT5.0不一定要求是TOMCAT,只要是支持servlet 2.2 API的就可以;我的是D:/Tomc...
  • jery_lee
  • jery_lee
  • 2004-08-02 14:11:00
  • 921

Axis入门(2)

怎么安装Axis 1)安装JDK1.3版或以上我的是D:/j2sdk1.4.22)安装TOMCAT5.0不一定要求是TOMCAT,只要是支持servlet 2.2 API的就可以;我的是D:/To...
  • techcrunch
  • techcrunch
  • 2008-04-09 01:54:00
  • 216

AXIS入门

怎么安装Axis 1)安装JDK1.3版或以上我的是D:/j2sdk1.4.22)安装TOMCAT5.0不一定要求是TOMCAT,只要是支持servlet 2.2 API的就可以;我的是D:/Tomc...
  • GodSpeed513
  • GodSpeed513
  • 2008-08-18 17:12:00
  • 498

Java WebService 简单实例 方式二(axis1直接调用方式)

  • 2017年07月27日 14:41
  • 86B
  • 下载
收藏助手
不良信息举报
您举报文章:Axis入门(2)
举报原因:
原因补充:

(最多只允许输入30个字)