百练2229:Sumsets题解

2229:Sumsets

总时间限制: 
2000ms 
内存限制: 
200000kB
描述
Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7:

1) 1+1+1+1+1+1+1
2) 1+1+1+1+1+2
3) 1+1+1+2+2
4) 1+1+1+4
5) 1+2+2+2
6) 1+2+4

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).
输入
A single line with a single integer, N.
输出
The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).
样例输入
7
样例输出
6
来源

USACO 2005 January Silver

代码:

#include<cstdio>  
#include<cstring>  
const int MAX=10000010;  
const int mod=1000000000;  
long long a[MAX]={0,1};  
int main(){         
    for(int i=2;i<MAX;i++){     
        if(i&1)  
        	a[i]=a[i-1];  
        else  
        	a[i]=(a[i/2]+a[i-1])%mod;   
    }  
    long long  n;  
    while(scanf("%lld",&n)!=EOF)  
    	printf("%lld\n",a[n]);
	return 0;  
}  





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值