POJ1700 Crossing River(贪心)

Crossing River
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 17179 Accepted: 6490

Description

A group of N people wishes to go across a river with only one boat, which can at most carry two persons. Therefore some sort of shuttle arrangement must be arranged in order to row the boat back and forth so that all people may cross. Each person has a different rowing speed; the speed of a couple is determined by the speed of the slower one. Your job is to determine a strategy that minimizes the time for these people to get across.

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. The first line of each case contains N, and the second line contains N integers giving the time for each people to cross the river. Each case is preceded by a blank line. There won't be more than 1000 people and nobody takes more than 100 seconds to cross.

Output

For each test case, print a line containing the total number of seconds required for all the N people to cross the river.

Sample Input

1
4
1 2 5 10

Sample Output

17

Source

POJ Monthly--2004.07.18

题目大意:给定n个人想要过河,每个人有一个时间消耗,只有一艘船,每次只能载两个人,问所消耗的最少时间是多少?

首先不能是耗时最少的人把所有人都送过河,这样的话时间消耗是全部的时间再加上时间最少的人从河对面回来的时间,但是如果将时间最长的和时间次长的组合,则消耗的时间只有一个最长的时间。

当n<4时,三种情况做特殊判断

当n>=4时,取两种情况下的最小值 

1.用最小的值将最大和次大的送过去,最小独自回来

2.最小和次小组合 最大和次大组合,最小和次小独自回来

#include <iostream>
#include <stdio.h>
#include <algorithm>
using namespace std;

int main()
{
    int t;
    int num[1005];

    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
            scanf("%d",&num[i]);
        int sum=0;
        sort(num+1,num+n+1);
        while(n>3)
        {
            sum+=min(num[1]*2+num[n]+num[n-1],num[n]+num[1]+num[2]*2);
            //printf("%d\n",sum);
            n=n-2;
        }
        if(n==1)
            sum+=num[1];
        if(n==2)
            sum+=num[2];
        if(n==3)
            sum+=num[1]+num[2]+num[3];
        printf("%d\n",sum);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值