贪心 crosing river

题目:

Description

A group of N people wishes to go across a river with only one boat, which can at most carry two persons. Therefore some sort of shuttle arrangement must be arranged in order to row the boat back and forth so that all people may cross. Each person has a different rowing speed; the speed of a couple is determined by the speed of the slower one. Your job is to determine a strategy that minimizes the time for these people to get across.

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. The first line of each case contains N, and the second line contains N integers giving the time for each people to cross the river. Each case is preceded by a blank line. There won't be more than 1000 people and nobody takes more than 100 seconds to cross.

Output

For each test case, print a line containing the total number of seconds required for all the N people to cross the river.

Sample Input

1
4
1 2 5 10

Sample Output

17


题解:

有T种情况,N个人,一条船,每次最多过两人,过河的时间是速度慢的人所需的时间,求所有人过河的最短时间。


将所有人过河所需的时间由小到大排序,依次由速度最快的两个人运送最慢的两个人过河。


有两种情况:1.T1+T2*2+Tn=T

                     2.2*T1+Tn-1+Tn=T

取最小值,当剩三个人的时候,写一个特判。


犯了一个比较弱智的问题,开数组的时候写进了循环里面,WA了好几次。



代码:

#include<stdio.h>
#include<algorithm>
using namespace std;
int main()
{
    int T ;
    int a[1005];
    scanf("%d",&T);
    while(T--)
    {
        int n,i;
        scanf("%d",&n);
        for(i=0;i<n;i++)
            scanf("%d",&a[i]);
            sort(a,a+n);
            int k=n-1;
            int sum=0;
            while(k>=0)
            {
                if(k>=3)
                {
                int t1 = a[0] + 2*a[1] + a[k];
                int t2 = 2*a[0] + a[k] + a[k-1];
                sum+=min(t1,t2);
                }
                else if(k==2)
                {
                    sum+=a[1]+a[2];
                }
                else
                {
                    sum+=a[k];
                }
                k-=2;
            }
            printf("%d\n",sum);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值