hdu-oj 1390 Binary Numbers

Binary Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2771    Accepted Submission(s): 1710


Problem Description
Given a positive integer n, find the positions of all 1's in its binary representation. The position of the least significant bit is 0.
Example
The positions of 1's in the binary representation of 13 are 0, 2, 3.
Task
Write a program which for each data set:
reads a positive integer n,
computes the positions of 1's in the binary representation of n,

writes the result.
 Input
The first line of the input contains exactly one positive integer d equal to the number of data sets, 1 <= d <= 10. The data sets follow.
Each data set consists of exactly one line containing exactly one integer n, 1 <= n <= 10^6.
 Output
The output should consists of exactly d lines, one line for each data set.
Line i, 1 <= i <= d, should contain increasing sequence of integers separated by single spaces - the positions of 1's in the binary representation of the i-th input number.
 Sample Input
  
  
1 13
 Sample Output
  
  
0 2 3
题目大意:将数据的2进制中1的位置输出(末尾记为0位置)
解题思路:将2进制1保存在数组中,方便记录位置。
注意:输出结果最后一位无空格。
附代码:
#include <stdio.h>
#include <string.h>
int a[1000000];
int main()
{  int n,m,i,j,k;
   scanf("%d",&n);
   while(n--){
      scanf("%d",&m);
      memset(a,0,sizeof(a));i=0;
      while(m){
        a[i++]=m%2;
        m/=2;
      }
      for(j=0;j<=i;j++){
         if(a[j]==1)
          { printf("%d",j);
         break;}     
      }
      for(k=j+1;k<=i;k++){
         if(a[k]==1)
           printf(" %d",k);
      }
      printf("\n");
   }
    return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值