POJ 3723 Conscription——————求森林最大权

Conscription

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 19544 Accepted: 6794
Description

Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to be his soldiers. To collect a soldier without any privilege, he must pay 10000 RMB. There are some relationships between girls and boys and Windy can use these relationships to reduce his cost. If girl x and boy y have a relationship d and one of them has been collected, Windy can collect the other one with 10000-d RMB. Now given all the relationships between girls and boys, your assignment is to find the least amount of money Windy has to pay. Notice that only one relationship can be used when collecting one soldier.

Input

The first line of input is the number of test case.
The first line of each test case contains three integers, N, M and R.
Then R lines followed, each contains three integers xi, yi and di.
There is a blank line before each test case.

1 ≤ N, M ≤ 10000
0 ≤ R ≤ 50,000
0 ≤ xi < N
0 ≤ yi < M
0 < di < 10000

Output

For each test case output the answer in a single line.
Sample Input

2

5 5 8
4 3 6831
1 3 4583
0 0 6592
0 1 3063
3 3 4975
1 3 2049
4 2 2104
2 2 781

5 5 10
2 4 9820
3 2 6236
3 1 8864
2 4 8326
2 0 5156
2 0 1463
4 1 2439
0 4 4373
3 4 8889
2 4 3133
Sample Output

71071
54223


中文意思
在这里插入图片描述

可以转化为无向图中的最大权森林问题
可以把变得权值变成负的然后可以用最小生成树算法求解

// #include<bits/stdc++.h>
#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;

typedef long long ll;
const int MAXN = 5e4+5;
int p[MAXN];
struct edge{
        int from,to,cost;
        edge(){};
        edge(int _from, int _to, int _cost){
                from = _from;
                to = _to;
                cost = _cost;
        }
}es[MAXN];

void init(int n){
        for(int i=0;i<=n;++i){
                p[i] = i;
         }
}
int find(int x){
        return p[x]==x?x:p[x]=find(p[x]);
}
void join(int x, int y){
        x = find(x);
        y = find(y);
        if(x!=y)        p[y] = x;
}

bool cmp(edge x, edge y){
        return x.cost<y.cost;
}


int main()
{
        // freopen("../in.txt","r",stdin);
        // freopen("../out.txt","w",stdout);
        int t,n,m,r,x,y,d;
        scanf("%d",&t);
        while(t--){
                scanf("%d %d %d",&n,&m,&r);
                init(n+m);
                for(int i=0;i<r;++i){
                        scanf("%d %d %d",&x,&y,&d);
                        es[i] = edge(x,n+y,-d);
                }
                sort(es,es+r,cmp);
                int sum = 0;
                for(int i=0;i<r;++i){
                        edge e = es[i];
                        if(find(e.from)!=find(e.to)){
                                sum += e.cost;
                                join(e.from, e.to);
                        }
                }
                printf("%d\n",10000*(n+m)+sum);

        }
        return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值