hdu Crixalis's Equipment

Problem Description
Crixalis - Sand King used to be a giant scorpion(蝎子) in the deserts of Kalimdor. Though he's a guardian of Lich King now, he keeps the living habit of a scorpion like living underground and digging holes.

Someday Crixalis decides to move to another nice place and build a new house for himself (Actually it's just a new hole). As he collected a lot of equipment, he needs to dig a hole beside his new house to store them. This hole has a volume of V units, and Crixalis has N equipment, each of them needs Ai units of space. When dragging his equipment into the hole, Crixalis finds that he needs more space to ensure everything is placed well. Actually, the ith equipment needs Bi units of space during the moving. More precisely Crixalis can not move equipment into the hole unless there are Bi units of space left. After it moved in, the volume of the hole will decrease by Ai. Crixalis wonders if he can move all his equipment into the new hole and he turns to you for help.
 


 

Input
The first line contains an integer T, indicating the number of test cases. Then follows T cases, each one contains N + 1 lines. The first line contains 2 integers: V, volume of a hole and N, number of equipment respectively. The next N lines contain N pairs of integers: Ai and Bi.
0<T<= 10, 0<V<10000, 0<N<1000, 0 <Ai< V, Ai <= Bi < 1000.
 


 

Output
For each case output "Yes" if Crixalis can move all his equipment into the new hole or else output "No".
 


 

Sample Input
  
  
2 20 3 10 20 3 10 1 7 10 2 1 10 2 11
 


 

Sample Output
  
  
Yes No

 

#include<stdio.h>
#include<string.h>
#include<algorithm>
 using namespace std;
//  struct IN
//    {
//    	int a;
//    	int b;
//    	int c;
//    }boy[1010];
//  int cmp(IN X,IN Y)   //贪心策略:将空间占用波动情况降序排序(即为将移动时的空间占用与放置时空间占用的差值) 
//    {
//    	return X.c>Y.c;
//    }
struct IN
    {
    	int a;
    	int b;
    }boy[1010];
  int cmp(IN X,IN Y)
    {
    	return X.a+Y.b<X.b+Y.a;//贪心策略:按照瞬时空间占用升序排,现将瞬时空间占用最小的放进去 
    }
  int main()
   {
   	int T;
   	int i,j,k;
   	int V ,n;
   	scanf("%d",&T);
   	while(T--)
   	  {
   	  	scanf("%d%d",&V,&n);
   	  	memset(boy,0,sizeof(boy));
   	  	 for(i=0;i<n;i++)
   	  	  {
   	  	  	scanf("%d%d",&boy[i].a,&boy[i].b);
   	  	  //	boy[i].c=boy[i].b-boy[i].a;
   	  	  }
   	  	sort(boy,boy+n,cmp);
   	  	  k=1;
   	  	 for(j=0;j<n;j++)
   	  	  {
   	  	  	if(V>=boy[j].b)
   	  	  	  {
   	  	  	  	V-=boy[j].a;
   	  	  	  }
   	  	  	else
   	  	  	  {
   	  	  	  	k=0;
				break;
   	  	  	  	
   	  	  	  }
   	  	  }
   	  	if(k==1)   printf("Yes\n");
   	  	else       printf("No\n");	     
   	  }
   	  return 0;
   }


 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值