hdu 2680 最短路径 多起点一终点问题

14 篇文章 0 订阅

Choose the best route

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 30   Accepted Submission(s) : 11
Font: Times New Roman | Verdana | Georgia
Font Size:  

Problem Description

One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.

Input

There are several test cases. 
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.

Output

The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.

Sample Input

5 8 5
1 2 2
1 5 3
1 3 4
2 4 7
2 5 6
2 3 5
3 5 1
4 5 1
2
2 3
4 3 4
1 2 3
1 3 4
2 3 2
1
1

Sample Output

1
-1

Author

dandelion

Source

2009浙江大学计算机研考复试(机试部分)——全真模拟


一道题改了好久,但是最终还是第一次代码不正确

//#include<stdio.h>
//#include<string.h>
//#define MAX 1000000000
//int map[1010][1010];
//int vis[1010];
//int dis[1010];
//int n,m,t;
//int w;
//void dijstra()
//{
//	int i,j;
//	int min,p;
//	int temp;
//	memset(vis,0,sizeof(vis));
//	for(i=0;i<=n;i++)
//	{
//		dis[i]=map[0][i];
//	}
//	dis[0]=0;
//	vis[0]=1;
//	for(i=0;i<=n;i++)
//	{
//		min=MAX;
//		for(j=0;j<=n;j++)
//		{
//			if(!vis[j]&&dis[j]<min)
//			{
//				min=dis[j];
//				temp=j;
//			}
//		}
//		vis[temp]=1;
//		for(p=0;p<=n;p++)
//		{
//			if(dis[p]>dis[temp]+map[temp][p])
//			{
//				dis[p]=dis[temp]+map[temp][p];
//			}
//		}
//	}
//}
//int main()
//{
//	int i,j;
//	int h,k;
//	int p,q,t;
//	while(scanf("%d%d%d",&n,&m,&t)!=EOF)
//	{
//		for(i=0;i<=n;i++)
//		{
//			for(j=0;j<=n;j++)
//			{
//				if(i!=j)
//					map[i][j]=MAX;
//				else
//					map[i][j]=0;
//			}
//		}
//		for(i=0;i<m;i++)
//		{
//			scanf("%d%d%d",&p,&q,&t);
//			if(t<map[p][q])
//			map[p][q]=t;
//		}
//		scanf("%d",&w);
//		for(i=0;i<w;i++)
//		{
//			scanf("%d",&h);
//			map[0][h]=0;
//		}
//		dijstra();
//		if(dis[n]>=MAX)
//			printf("-1\n");
//		else
//		   printf("%d\n",dis[n]);
//	}
//return 0;
//} 

#include<stdio.h>
#include<string.h>
#define MAX 10000000
int map[2010][2010];
int vis[1010];
int dis[1010];
int H[1010];
int n,m,s;
int w;
void dijstra(int begin)
{
	int i,j;
	int min,p;
	int temp;
	memset(vis,0,sizeof(vis));
	for(i=1;i<=n;i++)
	{
		dis[i]=map[begin][i];
	}
	dis[begin]=0;
	vis[begin]=1;
	for(i=1;i<=n;i++)
	{
		min=MAX;
		for(j=1;j<=n;j++)
		{
			if(!vis[j]&&dis[j]<min)
			{
				min=dis[j];
				temp=j;
			}
		}
		if(min==MAX)
		   break;
		vis[temp]=1;
		for(p=1;p<=n;p++)
		{
			if(!vis[p]&&dis[p]>dis[temp]+map[temp][p])
			{
				dis[p]=dis[temp]+map[temp][p];
			}
		}
	}
}
int main()
{
	int i,j;
	int h,k;
	int p,q,t;
	int Min;
	while(scanf("%d%d%d",&n,&m,&s)!=EOF)
	{
		for(i=1;i<=n;i++)
		{
			for(j=1;j<=n;j++)
			{
				if(i!=j)
					map[i][j]=MAX;
				else
					map[i][j]=0;
			}
		}
		for(i=0;i<m;i++)
		{
			scanf("%d%d%d",&p,&q,&t);
			if(t<map[q][p])
			map[q][p]=t;
		}
		scanf("%d",&w);
		for(i=0;i<w;i++)
		{
			scanf("%d",&H[i]);
		}
		dijstra(s);
		Min=MAX;
		for(i=0;i<w;i++)
		{
			if(Min>dis[H[i]])
				Min=dis[H[i]];
		}
		if(Min==MAX)
			printf("-1\n");
		else
		   printf("%d\n",Min);
	}
return 0;
} 






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值