HDU 1384 && POJ 1201--Intervals 【基础差分约束】

Intervals

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3270    Accepted Submission(s): 1206


Problem Description
You are given n closed, integer intervals [ai, bi] and n integers c1, ..., cn.

Write a program that:

> reads the number of intervals, their endpoints and integers c1, ..., cn from the standard input,

> computes the minimal size of a set Z of integers which has at least ci common elements with interval [ai, bi], for each i = 1, 2, ..., n,

> writes the answer to the standard output
 

Input
The first line of the input contains an integer n (1 <= n <= 50 000) - the number of intervals. The following n lines describe the intervals. The i+1-th line of the input contains three integers ai, bi and ci separated by single spaces and such that 0 <= ai <= bi <= 50 000 and 1 <= ci <= bi - ai + 1.

Process to the end of file.

 

Output
The output contains exactly one integer equal to the minimal size of set Z sharing at least ci elements with interval [ai, bi], for each i = 1, 2, ..., n.
 

Sample Input
  
  
5 3 7 3 8 10 3 6 8 1 1 3 1 10 11 1
 

Sample Output
  
  
6
 

题目大意:

给出一些区间[ai,bi]和每个区间最少需要几个点ci,然后问总共最少需要几个点满足所有区间的要求。比如给出1 5 2 4 6 2,就是说15需要2个点,46需要2个点,那么最少需要2个点就可以满足条件了。


思路:设s[i] 表示集合Z里面的元素在区间[ 0, i ]的个数,maxl, maxr 分别表示所有区间里面的最左端和最右端,dist[ ]数组存储源点到某点的最短路。则由题意得限制条件
一 s[right + 1] -  s[left]  >=  least 即 [left,  right] 区间中个数不小于least
二 0 <= S[i] - S[i-1] <= 1转换得 s[i + 1] - s[i] >= 0 && s[i] - s[i + 1] >= -1;
然后根据限制条件建图

</pre><pre name="code" class="cpp">#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <queue>
#define maxn 50050
#define INF 0x3f3f3f3f
using namespace std;

struct node {
	int u, v, w, next;
};

node edge[maxn * 4];
int head[maxn], cnt;
int dist[maxn];
bool vis[maxn];
int maxl, maxr; //区间最左段与最右端
void init(){
	cnt = 0;
	memset(head, -1, sizeof(head));
	maxr = 0;
	maxl = maxn;
}

void add(int u, int v, int w){
	edge[cnt] = {u, v, w, head[u]};
	head[u] = cnt++;
}

void SPFA(){
	for(int i = maxl; i <= maxr + 1; ++i){//集合的最左端为源点
		dist[i] = -INF;
		vis[i] = 0;
	}
	dist[maxl] = 0;
	queue<int>q;
	vis[maxl] = 1;
	q.push(maxl);
	while(!q.empty()){
		int u = q.front();
		q.pop();
		vis[u] = 0;
		for(int i = head[u]; i != -1; i = edge[i].next){
			int v = edge[i].v;
			int w = edge[i].w;
			if(dist[v] < dist[u] + w){ //最长路 
				dist[v] = dist[u] + w;
				if(!vis[v]){
					vis[v] = 1;
					q.push(v);
				}
			}
		}
	}
	printf("%d\n", dist[maxr + 1]);
	return ;
}


int main (){
	int T;
	while(scanf("%d", &T) != EOF){
		init();
		int x , y, num;
		while(T--){
			scanf("%d%d%d", &x, &y, &num);
			maxl = min(maxl, x);
			maxr = max(maxr, y);
			add(x, y + 1, num);
		}
		for(int i = maxl; i <= maxr + 1; ++i){
			add(i, i + 1, 0);
			add(i + 1, i, -1);
		}
		SPFA();
	}	
	return 0;
} 





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值