POJ 1466 && ZOJ 1137--Girls and Boys【二分图 && 最大点独立集】

20 篇文章 0 订阅
16 篇文章 0 订阅

Girls and Boys
Time Limit: 5000MS Memory Limit: 10000K
Total Submissions: 11134 Accepted: 4981

Description

In the second year of the university somebody started a study on the romantic relations between the students. The relation "romantically involved" is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been "romantically involved". The result of the program is the number of students in such a set.

Input

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description: 

the number of students 
the description of each student, in the following format 
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ... 
or 
student_identifier:(0) 

The student_identifier is an integer number between 0 and n-1 (n <=500 ), for n subjects.

Output

For each given data set, the program should write to standard output a line containing the result.

Sample Input

7
0: (3) 4 5 6
1: (2) 4 6
2: (0)
3: (0)
4: (2) 0 1
5: (1) 0
6: (2) 0 1
3
0: (2) 1 2
1: (1) 0
2: (1) 0

Sample Output

5
2
题意:

在大学的第二年有人开始研究男女学生之间的“浪漫”关系,所谓“浪漫”关系是在男女学生之间的,给你每个学生的编号以及他们之间的浪漫关系,请你找出一个最大的学生集合,使得这个集合里任意两个学生之间没有浪漫关系,求这个集合的学生人数。


解析:

赤裸裸的最大独立集的问题,先建二分图,还是最原始的拆点建图,每个点拆成左右两个点, 有关系的点之间建边,然后求最大匹配数,但这里要注意,由于关系是相互的,所以这里求出的最大匹配数是原来的二倍,要 / 2才对。

二分图的最大独立集 =二分图的点数 - 二分图的最大匹配数。


#include <cstdio>
#include <cstring>
#include <algorithm>
#define maxn 550
using namespace std;
int map[maxn][maxn];
int used[maxn];
int link[maxn];
int n;

void init(){
    memset(map, 0, sizeof(map));
}

void getmap(){
    for(int j = 0; j < n; ++j){
        int id, m, a;
        scanf("%d: (%d)", &id, &m);
        for(int i = 0; i < m; ++i){
            scanf("%d", &a);
            map[id][a] = 1;
        }
    }
}

bool dfs(int x){
    for(int i = 0; i < n; ++i){
        if(map[x][i] && !used[i]){
            used[i] = 1;
            if(link[i] == -1 || dfs(link[i])){
                link[i] = x;
                return true;
            }
        }
    }
    return false;
}

int hungary(){
    int ans = 0;
    memset(link, -1, sizeof(link));
    for(int i = 0; i < n; ++i){
        memset(used, 0, sizeof(used));
        if(dfs(i))
            ans++;
    }
    return ans;
}

int main (){
    while(scanf("%d", &n) != EOF){
        init();
        getmap();
        int sum = hungary();
        //printf("%d\n", sum);
        printf("%d\n", n - sum / 2);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值